uva529

  Addition Chains 

An addition chain for n is an integer sequence <!-- MATH: $$ -->$<a_0, a_1, a_2, \dots, a_m>$ with the following four properties:

  • a0 = 1
  • am = n
  • a0<a1<a2<...<am-1<am
  • For each k ( $1 \le k \le m$) there exist two (not neccessarily different) integers i and j ( $0 \le i, j \le k-1$) with ak =ai +aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.

For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing one integer n ( $1 \le n \le 10000$). Input is terminated by a value of zero (0) for n.

Output Specification 

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.


Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.

Sample Input 

5
7
12
15
77
0

Sample Output 

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77

经典题目

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int n,q[100],f[100],m;
int dfs(int h)
{
    if(h<m)
    {
        for(int i=h-1; i>=0; i--)
        {
            int c=q[i]+q[h-1];
            if(c<=n)
            {
                q[h]=c;
                if(c==n&&m>h)
                {
                    for(int j=0; j<=h; j++)
                        f[j]=q[j];
                    m=h;
                }
                else if(c*1<<(m-h-1)>=n)dfs(h+1);
            //c*1<<(m-h-1)是指在不超出的情况下c的最大增长
            }
        }
    }
}
int main()
{
    while(cin>>n&&n)
    {
        if(n==1)cout<<1<<endl;
        else
        {
            m=30;
            q[0]=1;
            dfs(1);
            for(int i=0; i<m; i++)
                cout<<f[i]<<' ';
            cout<<n<<endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值