POJ - 1852 - Ants 蚂蚁

原文:https://bafanglvren.ink/archives/27/

Poj - 1085 - Ants

题目地址

http://poj.org/problem?id=1852

原文地址

https://bafanglvren.ink/chapter1/Ants.html

题目

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

题意

一群蚂蚁在长度为1 cm的水平杆上行走,每根恒定速度为1 cm / s。当步行蚂蚁到达杆的一端时,它立即从杆上掉下来。当两只蚂蚁相遇时,他们转身开始向相反的方向行走。我们知道蚂蚁在杆子上的原始位置,不幸的是,我们不知道蚂蚁的行走方向。您的任务是计算所有蚂蚁掉下来所需的最小和最大时间。

分析

我们的任务是找出最小时间与最大时间。
当所有蚂蚁都朝向自己最近的一边行走,这种情况下不会发生相遇,所有蚂蚁掉下来的时间正好是最小时间。
当所有蚂蚁都朝向自己最远的一边行走,这种情况下可能发生相遇,假设蚂蚁A和蚂蚁B相遇。

相遇后会发生什么

当两只蚂蚁相交,可以认为它们保持原状继续前进,每只蚂蚁独立存在不必转身。

题解

import java.util.Scanner;

public class Main {
    static int cnt;
    static int length;
    static int n;
    static int pos;
    static Scanner cin;
    static int minT;
    static int maxT;

    public static void main(String[] args){
        cin = new Scanner(System.in);
        int cnt = cin.nextInt();

        for(int i = 0;i<cnt;i++) {
            int length = cin.nextInt();
            int n = cin.nextInt();

            //minT,maxT 归零
            minT = 0;
            maxT = 0;

            for(int j = 0;j<n;j++) {
                pos = cin.nextInt();
                minT = Math.max(Math.min(pos, length-pos), minT);
                maxT = Math.max(Math.max(pos, length-pos), maxT);
            }

            System.out.println(minT+" "+maxT);
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值