PAT Advanced 1028. List Sorting (25) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

Excel can sort records according to any column. Now you are supposed to
imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains
two integers N N N ( ≤ 1 0 5 \le 10^5 105 ) and C C C , where N N N is the number of records
and C C C is the column that you are supposed to sort the records with. Then N N N
lines follow, each contains a record of a student. A student’s record consists
of his or her distinct ID (a 6-digit number), name (a string with no more than
8 characters without space), and grade (an integer between 0 and 100,
inclusive).

Output Specification:

For each test case, output the sorting result in N N N lines. That is, if C C C =
1 then the records must be sorted in increasing order according to ID’s; if
C C C = 2 then the records must be sorted in non-decreasing order according to
names; and if C C C = 3 then the records must be sorted in non-decreasing order
according to grades. If there are several students who have the same name or
grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

思路

应该也是很基本的排序。三种排序选项,后两个还有二级排序。也没有什么特殊的处理,所以很简单。

代码

最新代码@github,欢迎交流

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

typedef struct {
    int ID;
    char name[9];
    int grade;
} Student, *pStudent;

/* increasing by ID */
int cmp1(const void *a, const void *b)
{
    pStudent s1 = *(pStudent*)a, s2 = *(pStudent*)b;
    return s1->ID - s2->ID;
}

/* non decreasing by name, then increasing by ID */
int cmp2(const void *a, const void *b)
{
    pStudent s1 = *(pStudent*)a, s2 = *(pStudent*)b;
    if(strcmp(s1->name, s2->name))
        return strcmp(s1->name, s2->name);
    else
        return s1->ID - s2->ID;
}

/* non decreasing by grade, then increasing by ID */
int cmp3(const void *a, const void *b)
{
    pStudent s1 = *(pStudent*)a, s2 = *(pStudent*)b;
    if(s1->grade - s2->grade)
        return s1->grade - s2->grade;
    else
        return s1->ID - s2->ID;
}

int main()
{
    int N, C;
    Student buffer[100000] = {0};
    pStudent students[100000] = {0}, *s = students;

    scanf("%d %d", &N, &C);
    for(int i = 0; i < N; i++, s++)
    {
        /* use a new struct buffer */
        *s = buffer + i;
        scanf("%d %s %d", &(*s)->ID, (*s)->name, &(*s)->grade);
    }

    if(C == 1)  /* increasing ID */
        qsort(students, N, sizeof(pStudent), cmp1);
    else if(C == 2)  /* non-decreasing name */
        qsort(students, N, sizeof(pStudent), cmp2);
    else  /* C == 3, non-decreasing grade */
        qsort(students, N, sizeof(pStudent), cmp3);

    for(int i = 0; i < N; i++)
        printf("%06d %s %d\n", students[i]->ID,
                               students[i]->name,
                               students[i]->grade);

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值