A1052 Linked List Sorting (25分)【C语言】

A1052 Linked List Sorting (25分)【C语言】

原题链接

题目描述:
A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

输入格式:
Each input file contains one test case. For each case, the first line contains a positive N (<10 ​5​​ ) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10 ​5​​ ,10 ​5​​ ], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

输出格式:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

输入样例:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

输出样例:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

实现代码:

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;
struct Node{
	int address, data, next;
	bool flag; //标价是否为有效结点 
}node[maxn];

bool cmp(Node a, Node b){
	if(!a.flag || !b.flag){
		return a.flag>b.flag; //有效结点在前,无效在后 
	}else{
		return a.data<b.data; //都是有效结点时,按数据递增顺序排列 
	}
}

int main()
{
	for(int i=0; i<maxn; ++i){
		node[i].flag = false;
	}
	int n, begin;
	scanf("%d%d", &n, &begin);
	int address, data, next;
	for(int i=0; i<n; ++i){
		scanf("%d%d%d", &address, &data, &next);
		node[address].address = address;
		node[address].data = data;
		node[address].next = next;
	}
	int count=0, p=begin; //count为有效结点数量 
	while(p!=-1){
		node[p].flag = true;
		count++;
		p = node[p].next;
	}
	if(count==0){ //没有有效结点时,进行特判 
		printf("0 -1\n");
	}else{ //对有效结点进行排序输出 
		sort(node, node+maxn, cmp);
		printf("%d %05d\n", count, node[0].address);
		for(int i=0; i<count; ++i){
			printf("%05d %d ", node[i].address, node[i].data);
			if(i<count-1){ //对最后一个结点进行特殊输出 
				printf("%05d\n", node[i+1].address);
			}else{
				printf("-1\n");
			}
		}
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值