PAT Advanced 1008. Elevator (20) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

The highest building in our city has only one elevator. A request list is made
up with N N N positive numbers. The numbers denote at which floors the elevator
will stop, in specified order. It costs 6 seconds to move the elevator up one
floor, and 4 seconds to move down one floor. The elevator will stay for 5
seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill
the requests on the list. The elevator is on the 0th floor at the beginning
and does not have to return to the ground floor when the requests are
fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer
N N N , followed by N N N positive numbers. All the numbers in the input are less
than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

思路

很简单的题目,注意最后停住了5秒的等待时间也要算在内(其实不注意反倒不会有问题)。

代码

最新代码@github,欢迎交流

#include <stdio.h>
int main()
{
    int N, time, cur, pre;

    scanf("%d", &N);
    for(pre = 0, time = 0; N--; pre = cur)
    {
        scanf("%d", &cur);
        if(cur > pre)   time += (cur - pre) * 6 + 5;
        else            time += (pre - cur) * 4 + 5;
    }

    printf("%d", time);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值