[poj]Maximum sum

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU

之前才做过leetcode上的

leetcode上还有一道题是求一个数组中的连续数字的最大和

这里要把数组分成两段,求两段的连续数字的最大和
0-i这一段的与Maximum Subarray的方法相同,一维的dp就可以求出。

求i+1到n这一段的最大连续数字和有点绕弯。总不能考虑n2的复杂度。
于是,从右向左遍历数组,同时维护两个数组,r和haha。数组r用来记录从选取当前点开始到n的最大连续数字之和,数组haha用来记录从当前j开始向后的最大的连续子序列之和。
最终,求最大的l[i]+haha[i+1]即可。
#include<iostream>
using namespace std;
int* l;
int* r;
int* haha;
int* num;
int n;
int dp(){
	l[0] = num[0];
	for(int i=1;i<n;i++){
		l[i] = max(num[i],l[i-1]+num[i]);
	}
	r[n-1] = num[n-1];
	haha[n-1] = num[n-1];
	for(int i=n-2;i>=0;i--){
		r[i] = max(num[i],num[i]+r[i+1]);
		haha[i] = max(haha[i+1],r[i]);
	}
	int ma = -10000;
	for(int i=0;i<n-1;i++){
		ma = max(ma,l[i]+haha[i+1]);
	}
	return ma;
}
int main(){
	int caseNum;
	scanf("%d",&caseNum);
	while(caseNum--){
		scanf("%d",&n);
		num = new int[n];
		l = new int[n];
		r = new int[n];
		haha = new int[n];
		for(int i=0;i<n;i++)
			scanf("%d",&num[i]);
		cout<<dp()<<endl;
		delete[] l;
		delete[] r;
		delete[] haha;
	}
	return 0;
}
ac

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值