[poj]2505 A multiplication game

Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either 
Stan wins. 
or 
Ollie wins. 
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

这个题很拈游戏是一类,但是这个的规律又比拈游戏要难找一点。

(1,9]   Stan赢

(9,18] Ollie赢

(18,162] Stan赢

(162,324] Ollie赢

。。。

。。。。。。

就是初始一个值为1,即表示从1开始乘,默认胜者为先行者

先行者将x乘以9,如果x>=n,则停止,先行者胜;否则,将x乘以2,此时默认的胜者不变。


#include<iostream>
using namespace std;

int main(){
	long long n;
	while(cin>>n){
		bool winner = true;
		long long x=1;
		while(n>x){
			x = x*9;
			if(n<=x)
				winner=false;
			x = x*2;
		}
		if(!winner)
			cout<<"Stan wins."<<endl;
		else
			cout<<"Ollie wins."<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值