fjnu 1550 A multiplication game

Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either
Stan wins.
or
Ollie wins.
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

 

KEY:好抽象的数学问题……算法是网上搜的……丢人……

当输入为N时,如果Stan在能赢,则说明之前的一轮Ollie无论出多少都不能赢。设当乘积为M且该Ollie发难(设Olliep)时,Stan有必赢的策略(不管Ollie出什么,Stan都出9,
    9
×MN,9×p×MN    p2
    
等价于MceilN / 2×8))    ceil为向上取整)
下面证明如果StanceilN/18)时有必赢的策略,则
    9
×ceilN/18)<N18×ceilN/18)≥N.
N = 18×k + r k10r18)代人上式即得。
(在1018之间,Ollie必赢,可手工验证。)

接着验证若StanceilN/18)时必输,则StanN时亦必输。只要Ollie2Stan即使出9也不能赢,Ollie接着出9,即赢。

Source:

# include 
< iostream >
# include 
< cmath >
using   namespace  std;

int  StanWin(unsigned  long   int  n)
{
    
if (2<=n&&n<=9)
    
{
        
return 1;
    }
 
    
if (n<2)
    
{
        
return 0;
    }
 
    
if(n>9)
    
{
        
return StanWin(ceil(n/18.0));
    }

}


int  main()
{
//    freopen("fjnu_1550.in","r",stdin);
    unsigned long int n;
    
while (cin>>n)
    
{
        
if (StanWin(n))
            cout
<<"Stan wins."<<endl;
        
else
            cout
<<"Ollie wins."<<endl;
    }

    
return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值