1、HDU 1106 排序
Problem Description
输入一行数字,如果我们把这行数字中的‘5’都看成空格,那么就得到一行用空格分割的若干非负整数(可能有些整数以‘0’开头,这些头部的‘0’应该被忽略掉,除非这个整数就是由若干个‘0’组成的,这时这个整数就是0)。
你的任务是:对这些分割得到的整数,依从小到大的顺序排序输出。
Input
输入包含多组测试用例,每组输入数据只有一行数字(数字之间没有空格),这行数字的长度不大于1000。
输入数据保证:分割得到的非负整数不会大于100000000;输入数据不可能全由‘5’组成。
Output
对于每个测试用例,输出分割得到的整数排序的结果,相邻的两个整数之间用一个空格分开,每组输出占一行。
Sample Input
0051231232050775
Sample Output
0 77 12312320
Source
POJ
Recommend
Eddy
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
char num[1010];
char s[1010][1010];
char t[1010];
int len;
while (cin>>num) {
len = (int)strlen(num);
int i = 0, j, k;
int count = 0;
int flag;
while (i < len) {
flag = 0;
for (j=0; num[i]!='5'&&i<len; ++i,++j) {
s[count][j] = num[i];
flag = 1;
}
if (flag) {
++count;
}
++i;
}
// for (i=0; i<count; ++i) {
// cout<<s[i]<<endl;
// }
for (i=0; i<count; ++i) {
len = (int)strlen(s[i]);
for (j=0; s[i][j]=='0'&&j<len; ++j);
if (j == len) {
memset(s[i], '\0', sizeof(char)*len);
s[i][0] = '0';
} else {
for (k=0; j<len; ++k,++j) {
s[i][k] = s[i][j];
}
for (; k<len; ++k) {
s[i][k] = '\0';
}
}
}
for (i=0; i<count-1; ++i) {
for (j=i+1; j<count; ++j) {
if (strlen(s[i]) > strlen(s[j])) {
strcpy(t, s[i]); strcpy(s[i], s[j]); strcpy(s[j], t);
} else if (strlen(s[i]) == strlen(s[j])) {
if (strcmp(s[i], s[j]) > 0) {
strcpy(t, s[i]); strcpy(s[i], s[j]); strcpy(s[j], t);
}
}
}
}
for (i=0; i<count-1; ++i) {
cout<<s[i]<<" ";
}
cout<<s[count-1]<<endl;
for (i=0; i<count; ++i) {
memset(s[i], '\0', sizeof(char)*1010);
}
}
return 0;
}
2、HDU 2070 Fibbonacci Number
题意:
斐波那契数列
解题思路:
可以每输入一个数,就去循环计算一下。我采用的方法是提前用一个数组把所有会用到的数列保存到数组中,输入一个数字后直接输出对应项。
Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:
f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)
Your program should be able to handle values of n in the range 0 to 50.
Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
Output
Print out the answer in a single line for each test case.
Sample Input
3
4
5
-1
Sample Output
2
3
5
Hint
Note:
you can use 64bit integer: __int64
Author
Lily
Source
浙江工业大学网络选拔赛
Recommend
linle
#include <iostream>
using namespace std;
int main()
{
__int64 f[60];
f[0] = 0, f[1] = 1;
int i;
for (i=2; i<=50; ++i) {
f[i] = f[i-1] + f[i-2];
}
int n;
while (cin>>n && n!=-1) {
cout<<f[n]<<endl;
}
return 0;
}
3、HDU 2072 单词数
题意:
统计一行句子的不同单词数。以”#”结束
解题思路:
每次读入一行句子以后,提取里面的单词,然后放入C++的set里面,最后输出set大小即可。
Problem Description
lily的好朋友xiaoou333最近很空,他想了一件没有什么意义的事情,就是统计一篇文章里不同单词的总数。下面你的任务是帮助xiaoou333解决这个问题。
Input
有多组数据,每组一行,每组就是一篇小文章。每篇小文章都是由小写字母和空格组成,没有标点符号,遇到#时表示输入结束。
Output
每组只输出一个整数,其单独成行,该整数代表一篇文章里不同单词的总数。
Sample Input
you are my friend
#
Sample Output
4
Author
Lily
Source
浙江工业大学网络选拔赛
Recommend
linle
#include <iostream>
#include <set>
#include <cstdio>
using namespace std;
int main()
{
set<string> word;
string s = "";
char c;
while (scanf("%c", &c) && c!='#') {
if ((c>='a'&&c<='z') ||(c>='A'&&c<='Z')) {
s += c;
} else if (c == ' ') {
if (s.length() > 0) {
word.insert(s);
}
s = "";
} else if (c == '\n') {
if (s.length() > 0) {
word.insert(s);
}
cout<<word.size()<<endl;
word.clear();
s = "";
}
}
return 0;
}
4、UVa 10420 List of Conquests(战利品列表)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <cstdlib>
using namespace std;
char s[200000];
char Country[2001][100];
struct _country {
char country[100];
int num;
}_Country[2001];
int cmp_string(const void *a, const void *b)
{
_country* x = (_country *)a;
_country* y = (_country *)b;
return strcmp(x->country, y->country);
}
int main()
{
int n;
while (cin>>n) {
getchar();
int count1 = 0, count2 = 0;
while (n--) {
int found = 0;
gets(s);
int len = (int)strlen(s);
for (int i=0; i<len&&isalpha(s[i]); ++i) {
Country[count1][i] = s[i];
}
for (int i=0; i<count2; ++i) {
if (strcmp(Country[count1], _Country[i].country) == 0) {
++_Country[i].num;
found = 1;
break;
}
}
if (0 == found) {
++_Country[count2].num;
strcpy(_Country[count2].country, Country[count1]);
count2++;
}
count1++;
}
qsort(_Country, count2, sizeof(_Country[0]), cmp_string);
for (int i=0; i<count2; ++i) {
cout<<_Country[i].country<<" "<<_Country[i].num<<endl;
}
for (int i=0; i<count1; ++i) {
memset(Country[i], '\0', sizeof(char)*100);
}
for (int i=0; i<count2; ++i) {
memset(_Country[i].country, '\0', sizeof(char)*100);
}
}
return 0;
}
5、南阳理工OJ 57 6174问题
描述
假设你有一个各位数字互不相同的四位数,把所有的数字从大到小排序后得到a,从小到大后得到b,然后用a-b替换原来这个数,并且继续操作。例如,从1234出发,依次可以得到4321-1234=3087、8730-378=8352、8532-2358=6174,又回到了它自己!现在要你写一个程序来判断一个四位数经过多少次这样的操作能出现循环,并且求出操作的次数
比如输入1234执行顺序是1234->3087->8352->6174->6174,输出是4
输入
第一行输入n,代表有n组测试数据。
接下来n行每行都写一个各位数字互不相同的四位数
输出
经过多少次上面描述的操作才能出现循环
样例输入
1
1234
样例输出
4
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int num[2000], count;
int get_next(int x);
int main()
{
int n;
while (cin>>n) {
while (n--) {
cin>>num[0];
count = 1;
while (1) {
num[count] = get_next(num[count-1]);
int found = 0;
for (int i=0; i<count; ++i) {
if (num[i] == num[count]) {
found = 1;
break;
}
}
if (found) {
break;
}
count++;
}
cout<<count<<endl;
}
}
return 0;
}
int get_next(int x)
{
int a, b, n;
char s[10];
sprintf(s, "%d", x);
n = strlen(s);
for (int i=0; i<n; ++i) {
for (int j=i+1; j<n; ++j) {
if (s[i] > s[j]) {
char t = s[i]; s[i] = s[j]; s[j] = t;
}
}
}
sscanf(s, "%d", &b);
for (int i=0; i<n/2; ++i) {
char t = s[i]; s[i] = s[n-i-1]; s[n-i-1] = t;
}
sscanf(s, "%d", &a);
return a - b;
}