hdu 1385 Minimum Transport Cost(Floyd打印路径)

Minimum Transport Cost


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9113    Accepted Submission(s): 2406




Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and


a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.


You must write a program to find the route which has the minimum cost.
 


Input
First is N, number of cities. N = 0 indicates the end of input.


The data of path cost, city tax, source and destination cities are given in the input, which is of the form:


a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN


c d
e f
...
g h


where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 


Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......


From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......


Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.


 


Sample Input
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0
 


Sample Output
From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21


From 3 to 5 :
Path: 3-->4-->5
Total cost : 16


From 2 to 4 :
Path: 2-->1-->5-->4

Total cost : 17


思路:此题基本就是纯裸的floyd,不作解释。

#include <limits.h>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <time.h>
#include <algorithm>
#include <iostream>
#include <iterator>
#include <queue>
#include <stack>
#include <string>
#include <vector>
//#define ONLINE_JUDGE
#define eps 1e-8
#define INF 0x7fffffff                                          //INT_MAX
#define inf 0x3f3f3f3f                                          //int??????????????????
#define FOR(i,a) for((i)=0;i<(a);(i)++)                          //[i,a);
#define MEM(a) (memset((a),0,sizeof(a)))
#define sfs(a) scanf("%s",a)
#define sf(a) scanf("%d",&a)
#define sfI(a) scanf("%I64d",&a)
#define pf(a) printf("%d\n",a)
#define pfI(a) printf("%I64d\n",a)
#define pfs(a) printf("%s\n",a)
#define sfd(a,b) scanf("%d%d",&a,&b)
#define sft(a,b,c)scanf("%d%d%d",&a,&b,&c)
#define for1(i,a,b) for(int i=(a);i<b;i++)
#define for2(i,a,b) for(int i=(a);i<=b;i++)
#define for3(i,a,b)for(int i=(b);i>=a;i--)
#define MEM1(a) memset(a,0,sizeof(a))
#define MEM2(a) memset(a,-1,sizeof(a))
#define LL __int64
const double PI = acos(-1.0);
template<class T> T gcd(T a, T b) { return b ? gcd(b, a % b) : a; }
template<class T> T lcm(T a, T b) { return a / gcd(a, b) * b; }
template<class T> inline T Min(T a, T b) { return a < b ? a : b; }
template<class T> inline T Max(T a, T b) { return a > b ? a : b; }
using namespace std;
template<class T>
T Mint(T a, T b, T c) {
    if (a>b) {
        if (c>b)
            return b;
        return c;
    }
    if (c>a)
        return a;
    return c;
}
template<class T>
T Maxt(T a, T b, T c) {
    if (a>b) {
        if (c>a)
            return c;
        return a;
    }
    else if (c > b)
        return c;
    return b;
}

const int maxn=505;
int T,n,m,k;
int g,h;
int a[maxn][maxn];
int path[maxn][maxn];
int tax[maxn];

void Floyd(){
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            path[i][j]=j;
        }
    }
    for(int k=1;k<=n;k++){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                if(a[i][k]+a[k][j]+tax[k]<a[i][j]){
                    path[i][j]=path[i][k];
                    a[i][j]=a[i][k]+a[k][j]+tax[k];
                }
                else if(a[i][k]+a[k][j]+tax[k]==a[i][j]){//字典序
                    if(path[i][j]>path[i][k])
                        path[i][j]=path[i][k];
                }
            }
        }
    }
}

void print(int a,int b){
    printf("Path: %d",a);
    int next=path[a][b];
    while(next!=b){
        printf("-->%d",next);
        next=path[next][b];
    }
    if(a!=b)
        printf("-->%d",b);
    putchar(10);
}

int main() {
    while(~sf(n)&&n){
        for2(i,1,n){
            for2(j,1,n){
                sf(a[i][j]);
                if(a[i][j]==-1)
                    a[i][j]=inf;
            }
        }
        for2(i,1,n)    sf(tax[i]);
        Floyd();
        while(sfd(g,h)){
            if(g==-1&&h==-1)    break;
            printf("From %d to %d :\n",g,h);
            print(g,h);
            printf("Total cost : %d\n\n",a[g][h]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值