POJ 1273 Drainage Ditches

Language:
Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 67387 Accepted: 26035

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

【题目分析】

    简单地网络流的模板题目。主要是感受一下网络流的算法。

#include <cstdio>
#include <iostream>
#include <cstring>
#define INF 1000000
using namespace std;
int u[501],v[501],h[501],ne[501],map[501],f[501];
int n,m,en=0,S,T;
void add(int a,int b,int r)  //正向存一个r的边,反向为0(无法退流)
{
	u[en]=a;v[en]=b;ne[en]=h[a];f[en]=r;h[a]=en++;
	u[en]=b;v[en]=a;ne[en]=h[b];f[en]=0;h[b]=en++;
}
bool tell()//一边bfs,既能判断是否可以进行增广,又可以增加网络流的效率
{
	memset(map,-1,sizeof map);
	int que[501];
	int head=0,tail=0;
	que[tail++]=S;
	map[S]=0;
	while (head<tail){
		int u=que[head++];
		for (int i=h[u];i!=-1;i=ne[i]){
			if (map[v[i]]==-1&&f[i]){
				map[v[i]]=map[u]+1;
				que[tail++]=v[i];
			}
		}
	}
	if (map[T]!=-1) return true;
	else return false;
}
int zeng (int k,int now)//进行增广路
{
	if (k==T) return now;
	int r=0;
	for (int i=h[k];i!=-1&&now>r;i=ne[i]){
		if (map[k]+1==map[v[i]]&&f[i]!=0){
			int t=zeng(v[i],min(now-r,f[i]));
			f[i]-=t;f[i^1]+=t;r+=t;
		}
	}
	if (!r) map[k]=-1;
	return r;
}
int dinic()//主体算法
{
	int r=0,t;
	while (tell()) while (t=zeng(S,INF)) r+=t;
	return r; 
}
int main()
{
	while(cin>>n>>m)
{	memset(u,-1,sizeof u);
	memset(v,-1,sizeof v);
	memset(h,-1,sizeof h);
	memset(ne,-1,sizeof ne);
	en=0;S=1;T=m;
	for (int i=1;i<=n;++i){
		int u,v,r;
		cin>>u>>v>>r;
		add(u,v,r);
	}
	cout<<dinic()<<endl;
}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值