POJ 1325 Machine Schedule

Language:
Machine Schedule
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13704 Accepted: 5860

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

【题目分析】

   这是一道最小覆盖的题目,那么AB两个机器裸裸的二分图,最大匹配等于最小覆盖就可以得到结果了。

然而至于为什么是最大匹配。如果我们把两个任务连一条边,那么a[i]与b[i]之间连接了一条边,这个任务既可以合并到a[i]中,也可以合并到b[i]中。合并的结果就是最少的点数,而且能使每一条线段的一个端点在这个点上。其实只要画出图来还是很形象的。

那么此时就是最小覆盖,最大匹配。匈牙利算法轻松解决,不过还是有坑,要注意机器刚开始的时候是在0模式上,所以0模式不需要加入匹配。

匈牙利算法推荐一个博客:http://blog.csdn.net/dark_scope/article/details/8880547

【代码】

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#define M(a) memset(a,0,sizeof a);
using namespace std;
int n,m,k;
int map[101][101],vis[101],match[101];
bool find(int x)
{
	for (int i=1;i<m;++i)
		if (vis[i]==0&&map[x][i]==1){
			vis[i]=1;
			if (match[i]==0||find(match[i]))
			{
				match[i]=x;
				return true;
			}
		}
	return false;
}
int main()
{
	while (scanf("%d",&n),n!=0){
		scanf("%d%d",&m,&k);
		M(match);
		M(vis);
		M(map);
		for (int i=1;i<=k;++i){
			int u,v;
			scanf("%*d%d%d",&u,&v);
			if (u*v!=0) map[u][v]=1;
		}
		int ans=0;
		for (int i=1;i<n;++i){
			memset(vis,0,sizeof vis);
			if (find(i)) ans++;
		}
		cout<<ans<<endl;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值