杭电 1003 Max Sum (动态规划)

Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

大意: 
  给出一个序列,求出序列中连续的数的和的最大值并输出连续数列中首尾的位置,比如6 -1 5 4 -7 中6-1+5+4=14为连续数列中和最大的。
  输入:
    先输入t,表示t组测试数据;
    每组测试数据第一个数为序列的个数;
  输出:
    输出要求的最大和,和求出的序列的首尾位置。
思路:
  用数组a[]记录序列中的数,对于a[i]只有两种可能 1.为一个序列的首  2.为一个序列的尾  用数组d[i]记录以第i个数结尾的序列的最大和,则
  d[i]=max(d[i-1]+a[i],a[i]),d[i-1]+a[i]和a[i]分别对应a[i]的两种情况。
  

#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
int a[100000+11];
int d[100000+11];
int main()
{
    int t;
    scanf("%d",&t);
    int k=0;
    while(t--)
    {
        int sum=0;
        int n,begin,end;    
        int max0=-1001;                            //max0必须小于所有可能的整数 
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        memset(d,0,sizeof(d));
        for(int i = 1 ; i <= n ; i++)
        {
            scanf("%d",&a[i]);
            d[i]=max(d[i-1]+a[i],a[i]);
            if(max0 < d[i])
            {
                max0=d[i];                        //记录序列和的最大值 
                end=i;                            //记录和最大的序列的尾 
            }
        }
        for(int i = end ; i >= 1 ; i--)
        {
            sum+=a[i];
            if(sum == max0)
            {
                begin=i;
            }

        }
        printf("Case %d:\n",++k);
        printf("%d %d %d\n",max0,begin,end);
        if(t)
        {
            printf("\n");                //注意输出格式 
        }

    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值