UVA-1584 Circular Sequence 环状序列

题目

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence “CGAGTCAGCT”, that is, the last symbol “T” in “CGAGTCAGCT” is connected to the first symbol “C”. We always read a circular sequence in the clockwise direction.
Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence.
Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).
Input
The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, ‘A’, ‘C’, ‘G’ and ‘T’, are allowed. Each sequence has length at least 2 and at most 100.
Output
Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence
for the test case.
Sample Input
2
CGAGTCAGCT
CTCC
Sample Output
AGCTCGAGTC
CCCT

思路和代码

  • 思路
    • 首先要理解题目,环状串表示呈线性串有很多表示方法,但是最小表示只有一种,本题需求解出最小表示。
    • 最小表示含义:对于这个环状串的任意两个线性串,从第一个字符开始比较,当某一个位置的字符不同时,该位置字符较小的串,字典序较小,另一个串则被pass,将所有的线性串两两比较,最后剩下的串即为“最小表示”。
    • 可以用一个变量a表示目前为止字典序最小串在输入串的起始位置,变量b表示另一个比较串的起始位置,两者相比,如果a>b,则更新a使之等于b;如果等于,则还需比较a之后的字符和b之后的字符,如果a+1>b+1,则更新a使之等于b;如果a+1=b+1,则继续比较其后字符,直至更新a或者比较结束。
    • 最后a即最小串在输入串的起始位置,用for循环依次输出即可。putchar(s[(i+ans)%n]);
  • 代码1
#include<stdio.h> 
#include<string.h>
#define maxn 105
const char* s;
int main(){
	int T;
	char s[maxn];
	scanf("%d",&T);
	while(T--){
		scanf("%s",s);
		int ans=0;
		int n=strlen(s);
		int i,j;
		for(i=0;i<n;i++){			//ans为假设的最小串的起始位置,i是与之比较的串的起始位置
			if(s[ans%n]>s[i%n]) ans=i;			//因为输入串为环形,故用 %以循环遍历。
			else if(s[ans]==s[i]){
				for(j=1;j<n;j++) {
					if(s[(ans+j)%n]>s[(i+j)%n]) ans=i;		
					else if(s[(ans+j)%n]<s[(i+j)%n]) break;
				}
			}
		}
		for(i=0;i<n;i++){
			putchar(s[(i+ans)%n]); 
		}	
		putchar('\n');
	}
	return 0;
}
  • 代码2(书上代码)
#include<stdio.h>
#include<string.h>
#define maxn 105

//环状串s的表示法p是否比表示法q的字典序小
int less(const char* s,int p,int q){
	int n = strlen(s);
	int i;
	for(i=0;i<n;i++)
		if(s[(p+i)%n]!= s[(q+i)%n])			//s[(p+i)%n] 返回ASCII码
			return s[(p+i)%n] < s[(q+i)%n];		//比较两者大小,返回0或1
	return 0;  //相等 
}

int main(){
	int T;
	char s[maxn];
	scanf("%d",&T);
	while(T--){
		scanf("%s",s);    //为什么用%s,而不是%c
		int ans=0;
		int n=strlen(s);
		for(int i =1;i <n ;i++) 
			if(less(s,i,ans)) ans=i;
		for(int i=0;i<n;i++)
		 	putchar(s[(i+ans)%n]);
		putchar('\n');
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值