poj 2492 A Bug's Life(带类别偏移并查集)

poj 2492 A Bug’s Life(带类别偏移并查集)
Time Limit: 10000ms Memory Limit: 65536kB

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint
Huge input,scanf is recommended.

Source
TUD Programming Contest 2005, Darmstadt, Germany


这个题目和食物链很像,本质都是带偏移量的并查集,属于并查集的高级综合应用。
本来以为写完了食物链这个题就没有问题了,一开始思路也很正确,但是总是WA。修正了一些类似提前结束程序却没有处理多余读入,类似输出格式错误的低级错误后。因为核心代码写不对,还是一直WA。时候反思了一下,我觉得其实我对带类别偏移的并查集不是理解地很彻底。趁这几天趁热打铁复习一下,做一个回顾。


不妨用match[i]表示i与root[i]的类别差,在本题中match[]为1表示是异性,用异或运算代替类别偏移加法。
两个关键点:
1.并查集路径压缩,设rx=root[x],不妨设match[rx]已经在用find(rx)计算root[rx]时候已经计算清楚(递归思想很重要!),那么match[x]=match[x]^match[rx]。
2.把x,y配对时候,要注意如果令root[find(x)]=y;那么match[find(x)]=match[x]^1,或如下代码写法。
写代码为了防止路径压缩前后一些数值的改变带来困惑,最好记下中间值。


Accepted    11904kB 294ms   1076 B  G++
#define MAX_N 2000

#include<stdio.h>

int cases,n,m,x,y,rx,ry;
int root[MAX_N+1],match[MAX_N+1];
bool flag;

int find(int x)
{
    int temp;
    if (root[x]==x)
        return x;
    else
    {
        temp=root[x];
        root[x]=find(root[x]);
        match[x]^=match[temp];
        return root[x];
    }
}

void test()
{
    for (int i=1;i<=n;i++)
        printf("%d ",root[i]);
    printf("\n");
    for (int i=1;i<=n;i++)
        printf("%d ",match[i]);
    printf("\n"); 
}

int main()
{
    scanf("%d",&cases);
    for (int loop=1;loop<=cases;loop++)
    {
        scanf("%d %d",&n,&m);
        printf("Scenario #%d:\n",loop);
        for (int i=1;i<=n;i++)
        {
            root[i]=i;
            match[i]=0;
        }
        flag=false;
        for (int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            if (flag)
                continue;
            rx=find(x);
            ry=find(y); 
            if (((rx==ry)&&(match[x]==match[y]))||
                ((x>n)||(x<=0)||(y>n)||(y<=0)))
            {
                printf("Suspicious bugs found!\n");
                flag=true;
            }
            if (rx!=ry)
            {
                match[ry]=match[x]^match[y]^1;
                root[ry]=rx;
            }
            //test();
        }
        if (!flag)
            printf("No suspicious bugs found!\n");
        if (loop!=cases)
            printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值