poj 2001 Shortest Prefixes(Tire树/字典树)

poj 2001 Shortest Prefixes(Tire树/字典树)
Time Limit: 1000ms Memory Limit: 65536kB

Description
A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.
In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.
An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.

Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source
Rocky Mountain 2004


本题的意思比较简单,维护一个小写字母单词的字典,并且求每一个单词的无歧义最短前缀。
那么可以用静态Tire树即字典树维护,注意一个优化,记录每个结点的分叉信息,方便判断是否是合法的无歧义前缀。


Accepted    2516kB  20ms    1091 B  G++ 

#include<stdio.h>
#include<memory.h>

const int WORDS=1000;
const int LEN=20;
const int NONE=-1;
const int LEAF=0;
const int SPLIT=1;
const int NOSPLIT=2;

int words=0;
char word[WORDS][LEN+1];
int nodes=1;
int tire[(WORDS+1)*(LEN+1)][27];//[info,'a','b',...,'z']
int len;

void search(int root,char* str,int l)
{
    if ((tire[root][0]==NOSPLIT) || ((*str)=='\0'))
    {
        len=l;
        return;
    }
    else
        search(tire[root][(*str)-'a'+1],str+1,l+1);
    return; 
}

void insert(int root,char* str)
{
    if ((*str)=='\0')
    {
        tire[root][0]=LEAF;
        return;
    }
    else
    {
        if (tire[root][(*str)-'a'+1]==NONE)
        {
            tire[root][(*str)-'a'+1]=nodes;
            tire[nodes][0]=NOSPLIT;
            nodes++;
        }
        else
            tire[tire[root][(*str)-'a'+1]][0]=SPLIT;
        insert(tire[root][(*str)-'a'+1],str+1);
    }
    return;
}

int main()
{
    memset(tire,NONE,sizeof(tire));
    tire[0][0]=SPLIT;
    while (scanf("%s\n",word[words])!=EOF)
    {
        insert(0,word[words]);
        words++;
    }
    for (int i=0;i<words;i++)
    {
        printf("%s ",word[i]);
        search(0,word[i],0);
        for (int j=0;j<len;j++)
            printf("%c",word[i][j]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值