poj 3243 A Simple Problem with Integers(线段树+dirty维护)

poj 3243 A Simple Problem with Integers(线段树+dirty维护)
Time Limit: 5000ms 单个测试点时间限制: 2000ms Memory Limit: 131072kB

Description
You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint
The sums may exceed the range of 32-bit integers.

Source
POJ Monthly–2007.11.25, Yang Yi


线段树题目,但是为了节省写回时候的时间,引入dirty标记是否没有写回。
另外一定要注意long long!尤其注意scanf(“%lld”,&x),printf(“%lld”,x)和函数返回值!


Accepted    25552kB 860ms   1461 B  G++
#include<stdio.h>

const int LEN=1000000;
typedef long long int LL;
typedef LL array_type[LEN];

LL n;
array_type a,tree,dirty;

void add(LL now,LL l,LL r,LL x,LL y,LL dx)
{
    //printf("[%d,%d] [%d,%d]\n",l,r,x,y);
    LL mid=(l+r)/2;
    tree[now]+=(y-x+1)*dx;
    if (l==x && r==y)
    {
        if (l<=r)
            dirty[now]+=dx;
    }
    else
    {
        if (dirty[now])
        {
            add(2*now+1,l,mid,l,mid,dirty[now]);
            add(2*now+2,mid+1,r,mid+1,r,dirty[now]);
            dirty[now]=0;
        }
        if (mid>=y)
            add(now*2+1,l,mid,x,y,dx);
        else if (mid<x)
            add(now*2+2,mid+1,r,x,y,dx);
        else
        {
            add(now*2+1,l,mid,x,mid,dx);
            add(now*2+2,mid+1,r,mid+1,y,dx);
        }
    }
    return;
}

LL query(LL now,LL l,LL r,LL x,LL y)
{
    LL mid=(l+r)/2;
    if (dirty[now])
    {
        add(2*now+1,l,mid,l,mid,dirty[now]);
        add(2*now+2,mid+1,r,mid+1,r,dirty[now]);
        dirty[now]=0; 
    }   
    if (l==x && r==y)
        return tree[now];
    else if (mid>=y)
        return query(now*2+1,l,mid,x,y);
    else if (mid<x)
        return query(now*2+2,mid+1,r,x,y);
    else
        return query(now*2+1,l,mid,x,mid)+query(now*2+2,mid+1,r,mid+1,y); 
}

int main()
{
    LL m,x,y,dx;
    char c;
    scanf("%lld %lld\n",&n,&m);
    for (int i=1;i<=n;i++)
        scanf("%lld\n",&a[i]);
    for (int i=1;i<=n;i++)
        add(0,1,n,i,i,a[i]);
    /*for (int i=0;i<=4*n;i++)
        printf("%d ",tree[i]);*/
    while (m--)
    {
        scanf("%c %lld %lld",&c,&x,&y);
        if (c=='Q')
        {
            scanf("\n");
            printf("%lld\n",query(0,1,n,x,y));
        }
        else
        {
            scanf(" %lld\n",&dx);
            add(0,1,n,x,y,dx);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值