ACM-ICPC国际大学生程序设计竞赛北京赛区(2015)网络赛A题2015-9-20

[PKU A题] (http://hihocoder.com/contest/acmicpc2015beijingonline/problem/1)
题目描述:
题目1 : The Cats’ Feeding Spots
时间限制:1000ms
单点时限:1000ms
内存限制:256MB
描述
In Yan Yuan, the Peking University campus, there are many homeless cats. They all live happy lives because students founded a Cat Association to take care of them. Students not only feed them, but also treat their illness and sterilize some of them. Students make many feeding spots for the cats and cats always gather around those spots and make a lot of noise at night. Now the university authorities decide to restrict the number of feeding spots. This is the conversation between an officer and Rose Li, the director of Cat Association, and also a ACMer.

“Rose, From now on, you can’t build any new feeding spots any more. But I want you to keep exactly N feeding spots, and you should make the area which contains the feeding spots as small as possible!”

“Oh, do you mean that we should find a smallest convex hull which contains N spots?”

“Convex hull? What is a convex hull? Please speak Chinese!”

“All right, forget the convex hull. So what do you mean the ‘area’, what’s its shape?”

“It means… and the shape? Oh… let’s do it this way: you can choose any feeding spot as center, and then draw a circle which includes exactly N spots. You should find the smallest circle of such kind, and then we remove all feeding spots outside that circle.”

Although this way sounds a little bit ridiculous, Rose still writes a program to solve the problem. Can you write the program?

输入
The first line is an integer T (T <= 50), meaning the number of test cases.

Then T lines follow, each describing a test case.

For each test case:

Two integer M and N go first(1 <= M, N <= 100), meaning that there are M feeding spots originally and Rose Li has to keep exactly N spots.

Then M pairs of real numbers follow, each means a coordinate of a feeding spot in Yan Yuan. The range of coordinates is between [-1000,1000]

输出
For each test case, print the radius of the smallest circle. Please note that the radius must be an POSITIVE INTEGER and no feeding spots should be located just on the circle because it’s hard for the campus gardeners to judge whether they are inside or outside the circle. If there are no solution, print “-1” instead.

样例输入
4
3 2 0 0 1 0 1.2 0
2 2 0 0 1 0
2 1 0 0 1.2 0
2 1 0 0 1 0
样例输出
1
2
1
-1

此题为水体,正确率与H题不相上下,但是如何处理已经记录下来的数据需要好好思考一下,最佳方案是不选择二维数组,而是要选择一维数组进行数据存储,并进行扩展圆圈,但是一定要考虑清楚边界问题。
代码实现如下:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

struct node
{
    double x;
    double y;
} point[110];

int min(int a,int b)
{
    return a<b?a:b;
}

int main()
{
    int T;
    int m,n;
    int ii,jj;
    int flag;
    double dis[110];
    int ans[110];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&m,&n);
        for(int i=0; i<m; i++)
        {
            scanf("%lf%lf",&point[i].x,&point[i].y);
        }
        int minn=0xfffffff;
        for(int i=0; i<m; i++)//一个循环实现了数据记录,排序,还有求最小值
        {
            memset(dis,0,sizeof(dis));
            for(int j=0;j<m;j++)
            {
                dis[j]=sqrt((point[j].x-point[i].x)*(point[j].x-point[i].x)+(point[j].y-point[i].y)*(point[j].y-point[i].y));

            }
            sort(dis,dis+m);
            int ans=(int)dis[n-1]+1;//把半径扩展,实现把第前n个点都先放进圈里,之后再判断会不会把第n+1个点放进圈里
            if(n==m)
            {
                minn=min(minn,ans);
            }
            else if(n>m)
            {
                minn=-1;break;
            }
            else
            {
                if(ans<dis[n])//如果被扩展后的圈并不能把第n+1个点容纳进去,则把其记下来即可
                {
                    minn=min(minn,ans);
                }
                else continue;//如果已经把第n+1个点包含进去了,那就证明不能以该点为圆心做圆圈了
            }
        }
        if(minn==0xfffffff)
        printf("-1\n");
        else
        {
            printf("%d\n",minn);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值