HDU-1212 Big Number

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8022    Accepted Submission(s): 5535

Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.To make the problem easier, I promise that B will be smaller than 100000.Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
   
   
2 3 12 7 152455856554521 3250
 

Sample Output
    
    
2 5 1521
 

Author
Ignatius.L
 

Source
 

Recommend
Eddy
 

Statistic |  Submit |  Discuss |  Note




前面的数对后面的数取余




AC代码:
#include<iostream>
#include<cstring>
using namespace std;

char str[1100];

int main()
{
	long m,n,i,j;
	while(cin>>str)
	{
		cin>>n;
		j=strlen(str);
		m=0;
		for(i=0;i<j;i++)
		{
			m=m*10+str[i]-'0';
			m%=n; 
		}
		cout<<m<<endl;
	}
	return 0;
}#include<iostream>
#include<cstring>
using namespace std;

char str[1100];

int main()
{
	long m,n,i,j;
	while(cin>>str)
	{
		cin>>n;
		j=strlen(str);
		m=0;
		for(i=0;i<j;i++)
		{
			m=m*10+str[i]-'0';
			m%=n; 
		}
		cout<<m<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值