POJ-1852 ants

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17728 Accepted: 7532

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

Waterloo local 2004.09.19



题意:

有N个蚂蚁在长度为Lm的杆子上以1m/s的速度爬行,它们走到杆的边缘就会落下去,并且当他们相遇时,都会回头爬行,现在告诉你N个蚂蚁距离杆子左边的距离,但不知道它们爬行的方向,求它们完全掉下去时所花的最短时间和最长时间。



题解:

这是一道思(shui)路(ti)题,仔细思索就会发现,它们相遇时回不回头根本没关系(相当于附体到相遇的蚂蚁上继续爬)



代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;

int L, n;
int a[1000005] = { 0 };

int main()
{
	int T;
	cin >> T;
	while (T--)
	{
		int minT, maxT;
		minT = maxT = 0;
		cin >> L >> n;
		for (int i = 0; i < n; i++)
		{
			cin >> a[i];
			minT = max(minT, min(a[i], L - a[i]));
			maxT = max(maxT, max(a[i], L - a[i]));
		}
		cout << minT << " " << maxT << endl;
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值