[HDU 2084] 数塔 - 动态规划

Question

Link to the question: HDU 2084

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
请添加图片描述
已经告诉你了,这是个DP的题目,你能AC吗?

Input:
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。

Output:
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。

Sample Input:
1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output:
30

Stragedy

For each number, we are going to add the biggest ontop of it.
This is what going to happen after it is changed.

4     5     2     6     5
   7    12    10    10
     20    13    10
        23    21
           30

Lastly, we print the bottum number (lst[1][1]), which is 30.

状态转移方程: dp[i][j]+=max(lst[j+1][i],lst[j+1][i+1])

Code

No need to say what next:)
c++

#include <bits/stdc++.h>
using namespace std;
int main(){
    int num,i,n,j,lst[102][102]={0};
    ios::sync_with_stdio(0);
    cin>>num;
    while (num--){
        memset(lst,0,sizeof(lst));
        cin>>n;
        j=1;
        while(j<=n){
            for (i=1;i<=j;i++) {
                cin>>lst[j][i];
            }
            j++;
        }
        j-=2;
        while(j>0){
            for (i=1;i<=j;i++) lst[j][i]+=max(lst[j+1][i],lst[j+1][i+1]);
            j--;
        }
        cout<<lst[1][1];
    }
    return 0;
}

😊

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值