PAT A1048 Find Coins (25分)——二分查找实现

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤10​3, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1​​ and V​2(separated by a space) such that V1+V​2​​=M and V​1≤V​2. If such a solution is not unique, output the one with the smallest V1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

题意:

第一行输入硬币个数N和商品价格M,第二行输入每个硬币的面值;输出两枚面值和为M的硬币面额V1、V2,要求V1<=V2,如果输出结果不唯一,输出V1值最小的那组,如果没有满足条件的结果则输出No Solution.

思路:

(1)设计一个二分查找函数,参数为数组a[]、下界left、上界right和待查找整数x,找出数组a中是否存在等于x的元素a[i],如果存在这个元素则输出i,否则输出-1 ;
(2)使用二分查找函数前必须对数组a非递减排序.

代码:

#include <cstdio>
#include <algorithm>
using namespace std;

int binarySearch(int a[],int left,int right,int x){//二分查找,找出数组a中是否存在等于x的元素a[i],如果存在这个元素则输出i,否则输出-1 
	int mid;
	while(left<=right){
		mid = (left+right)/2;
		if(a[mid]==x) return mid;
		else if(a[mid]>x) right = mid-1;
		else left = mid+1;
	}
	return -1;
} 

int main(){
	int N,M;
	scanf("%d %d",&N,&M);
	int V[N];
	for(int i=0;i<N;i++){
		scanf("%d",&V[i]);
	}
	sort(V,V+N);//非递减排序
	for(int i=0;i<N;i++){
		int j = binarySearch(V,i+1,N-1,M-V[i]);//因为数组V非递减,且题目要求V[i]<=V[j],所以将下界设为i+1
		if(j!=-1){
			printf("%d %d\n",V[i],V[j]);
			return 0;
		}
	}
	printf("No Solution\n");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值