[PAT A1048]Find Coins

[PAT A1048]Find Coins

题目描述

1048 Find Coins (25 分)Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

输入格式

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

输出格式

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.

输入样例1

8 15
1 2 8 7 2 4 11 15

输出样例1

4 11

输入样例2

7 14
1 8 7 2 4 11 15

输出样例2

No Solution

解析

  1. 这道题的大意是,首先输入n和m,n表示硬币的总数,m表示总和,然后输入n个正整数,表示有n个硬币,我们需要做的就是判断有没有两枚硬币加起来之和为m,如果有多组,用v1,v2表示这两个数,要求v1<v2的时候,并且给出最小的v1的那组数据。
  2. 这道题目是散列题,不过可以通过多种方式实现,我把所有的方法都给出来希望读者看完后能够自己动手把它敲出来。
  3. 散列:
#include<iostream>
#include<string>
#include<map>
using namespace std;
int main()
{
 int n, all;
 map<int, int> mapp;
 scanf("%d %d", &n, &all);
 for (int i = 0; i < n; i++) {
  int temp;
  scanf("%d", &temp);
  mapp[temp]++;
 }
 bool judge = false;
 for (auto it : mapp) {
  int a = it.first;
  int b = all - it.first;
  if (mapp.find(b) != mapp.end()) {
   if (a == b &&it.second == 1) continue;
   else {
    judge = true;
    printf("%d %d", a, b);
    break;
   }
  }
 }
 if (!judge) printf("No Solution");
 return 0;
}
  1. 通过自己写二分搜索查找:
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int num[100010] = { 0 };
int main()
{
 int n, all;
 scanf("%d %d", &n, &all);
 for (int i = 0; i < n; i++) {
  int temp;
  scanf("%d", &num[i]);
 }
 sort(num, num + n);
 bool judge = false;
 for (int i = 0; num[i] <= all - num[i]; i++) {
  int des = all - num[i];
  int left = i + 1, right = n;
  while (left <= right) {
   int mid = (left + right) / 2;
   if (num[mid] == des) {
    judge = true;
    printf("%d %d", num[i], des);
    break;
   }
   else if (des < num[mid]) {
    right = mid - 1;
   }
   else left = mid + 1;
  }
  if (judge)break;
 }
 if (!judge)printf("No Solution");
 return 0;
}
  1. 这里要说的是,我们可以通过stl中的binary_search函数,而不用自己写二分查找,这样我们就可以简化代码:
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int num[100010] = { 0 };
int main()
{
 int n, all;
 scanf("%d %d", &n, &all);
 for (int i = 0; i < n; i++) {
  int temp;
  scanf("%d", &num[i]);
 }
 sort(num, num + n);
 bool judge = false;
 for (int i = 0; num[i] <= all - num[i]; i++) {
  int des = all - num[i];
  int left = i + 1, right = n;
  if (binary_search(num + i + 1, num + n, des)) {
   printf("%d %d", num[i], des);
   judge = true;
   break;
  }
 }
 if (!judge)printf("No Solution");
 return 0;
}
  1. Two Pointer方法:
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int num[100010] = { 0 };
int main()
{
 int n, all;
 scanf("%d %d", &n, &all);
 for (int i = 0; i < n; i++) {
  int temp;
  scanf("%d", &num[i]);
 }
 sort(num, num + n);
 bool judge = false;
 int i = 0, j = n - 1;
 while (i < j) {
  if (num[i] + num[j] == all) {
   printf("%d %d", num[i], num[j]);
   break;
  }
  else if (num[i] + num[j] > all) j--;
  else i++;
 }
 if (i >= j) printf("No Solution");
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值