题目描述
a[1]=a[2]=a[3]=1
a[x]=a[x-3]+a[x-1] (x>3)
求a数列的第n项对1000000007(10^9+7)取余的值。
输入格式:
第一行一个整数T,表示询问个数。
以下T行,每行一个正整数n。
输出格式:
每行输出一个非负整数表示答案。
输入样例#1:
3
6
8
10
输出样例#1:
4
9
19
说明
对于30%的数据 n<=100;
对于60%的数据 n<=2*10^7;
对于100%的数据 T<=100,n<=2*10^9;
矩阵乘法
自己推了一种
[ F n , F n + 1 , F n + 2 , F n + 3 ] = [ F n − 1 , F n , F n + 1 , F n + 2 ] ∗ [ 0 0 1 0 1 0 0 1 0 1 1 0 0 0 0 1 ] [F_n,F_{n+1},F_{n+2},F_{n+3}]=[F_{n-1},F_{n},F_{n+1},F_{n+2}]*\left[\begin{array}{ccc}0&0&1&0\\1&0&0&1\\0&1&1&0\\0&0&0&1 \end{array}\right] [Fn,Fn+1,Fn+2,Fn+3]=[Fn−1,Fn,Fn+1,Fn+2]∗⎣⎢⎢⎡0100001010100101⎦⎥⎥⎤
#include <cstring>
#include <iostream>
using namespace std;
static const auto io_sync_off = []() {
std::ios::sync_with_stdio(false);
std::cin.tie(nullptr);
return nullptr;
}();
using ll = long long;
const int mod = 1e9 + 7;
int T, n;
void mul(int f[4], int a[4][4])
{
int c[4];
memset(c, 0, sizeof(c));
for (int i = 0; i < 4; ++i)
for (int j = 0; j < 4; ++j)
c[i] = (c[i] + (ll)f[j] * a[j][i]) % mod;
memcpy(f, c, sizeof(c));
}
void mulself(int a[4][4])
{
int c[4][4];
memset(c, 0, sizeof(c));
for (int i = 0; i < 4; ++i)
for (int j = 0; j < 4; ++j)
for (int k = 0; k < 4; ++k)
c[i][j] = (c[i][j] + (ll)a[i][k] * a[k][j]) % mod;
memcpy(a, c, sizeof(c));
}
int main()
{
cin >> T;
while (T--)
{
cin >> n;
int f[4] = {1, 1, 1, 2};
int a[4][4] = {{0, 0, 1, 0}, {1, 0, 0, 1}, {0, 1, 1, 0}, {0, 0, 0, 1}};
for (n -= 1; n; n >>= 1)//递推式下标从0开始,所以减一
{
if (n & 1)
mul(f, a);
mulself(a);
}
cout << f[0] << endl;
}
return 0;
}
看解析发现有更简单的
[ F n , F n − 1 , F n − 2 ] = [ F n − 1 , F n − 2 , F n − 3 ] ∗ [ 1 1 0 0 0 1 1 0 0 ] [F_n,F_{n-1},F_{n-2}]=[F_{n-1},F_{n-2},F_{n-3}]*\left[\begin{array}{ccc}1&1&0\\0&0&1\\1&0&0\end{array}\right] [Fn,Fn−1,Fn−2]=[Fn−1,Fn−2,Fn−3]∗⎣⎡101100010⎦⎤
if (n < 3)
{
cout << 1 << endl;
continue;
}
int f[3] = {1, 1, 1};
int a[3][3] = {{1, 1, 0}, {0, 0, 1}, {1, 0, 0}};
for (n -= 3; n; n >>= 1)//减3
{...}