pta6-5 统计单词数量(文件)(*) (20分)

题目信息

请编写函数,统计英文文章的单词数量。
函数原型

int CountWord(FILE *f);

说明:参数 f 为文件指针。函数值为该文件的单词数量。

裁判程序

#include <stdio.h>
#include <stdlib.h>
#include <ctype.h>

int CountWord(FILE *f);

int main()
{
    FILE *f;
    int n;
    f = fopen("Story.txt", "r");
    if (!f)
    {
        puts("文件无法打开!");
        exit(1);
    }

    n = CountWord(f);

    if (fclose(f))
    {
        puts("文件无法关闭!");
        exit(1);
    }

    printf("单词数: %d\n", n);
    return 0;
}

/* 你提交的代码将被嵌在这里 */

打开 Windows 记事本软件,复制下面的文章内容,保存文件并命名为“Story.txt”。
Story.txt

A Cure for a Headache

One day a man went into a chemist’s shop and said, “Have you anything
to cure a headache?” The chemist took a bottle from a shelf, held it
under the gentleman’s nose and took out the cork. The smell was so
strong that tears came into the man’s eyes and ran down his cheeks.
“What did you do that for?” he said angrily, as soon as he could get
back his breath. “But that medicine has cured your headache, hasn’t
it?” said the chemist. “You fool,” said the man, “It’s my wife that
has the headache, not me!”

样例输入

(无)

输出样例

单词数: 108

注:一串连续的字母被定义为一个单词。

我的代码

int CountWord(FILE *f)
{
    int count=0;
    char word[41];
    while(fscanf(f,"%s",word) == 1)//一般的单词可以用%s来统计数量
    {
        for(int i=0; word[i]; i++)//遍历单词的每个字符
        {
            if(word[i]=='\'')//如果遇到 ' 代表两个单词(如it's)
            {
                count++;
                break;
            }
        }
        count++;
    }
    return count;
}

代码优势

简洁易用
抛弃了传统的计算单词的方法,一句while(fscanf(f,"%s",word) == 1)完成了传统方法十几行代码的工作。博客主PengZyi 原创

  • 10
    点赞
  • 16
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值