1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:

12345

Sample Output:

one five

这道题目与PAT 基础层次1002题几乎一样,所以用类似的解法解决。具体思路见PAT Basic Level1002。

#include<stdio.h>

int main ( void )
{
    char number;
    int sum = 0;
    while ( (number = getchar()) != '\n') {
        sum += ( number - '0' );
    }

    int digit[ 10] = { 0 };
    int i = 0;
    while ( sum != 0 ){
        digit[ i++ ] = sum % 10;
        sum /= 10;
    }

    int j;
    for ( j = i - 1; j >= 0; j-- ){
        if ( j == 0 ){
            switch( digit[ j ] ){
                case 1: printf("one"); break;
                case 2: printf("two"); break;
                case 3: printf("three"); break;
                case 4: printf("four"); break;
                case 5: printf("five"); break;
                case 6: printf("six"); break;
                case 7: printf("seven"); break;
                case 8: printf("eight"); break;
                case 9: printf("nine"); break;
                case 0: printf("zero"); break;
            }
        }else {
            switch( digit[ j ] ){
                case 1: printf("one "); break;
                case 2: printf("two "); break;
                case 3: printf("three "); break;
                case 4: printf("four "); break;
                case 5: printf("five "); break;
                case 6: printf("six "); break;
                case 7: printf("seven "); break;
                case 8: printf("eight "); break;
                case 9: printf("nine "); break;
                case 0: printf("zero "); break;
            }
        }
    }
    return 0;
}

自己做完之后,又去看了一眼别人的解法,发现思路虽然差不多,但是他的代码量比我少了好多,贴在这里:

#include<stdio.h>
int main()
{
    char num[102],word[10][6]={"zero","one","two","three","four","five","six","seven","eight","nine"};
    int sum,i;
    scanf("%s",num);
    for(i=0;num[i];i++)
    {
        sum+=(num[i]-'0');
    }
    sprintf(num,"%d\0",sum);//将整数转化为字符串
    printf("%s",word[num[0]-'0']);
    for(i=1;num[i];i++)
        printf(" %s", word[num[i]-'0']);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值