ACM—— Basically Speaking

The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.

Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

It will support bases 2 through 16.
Input
The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.
Output
The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR’’ (without the quotes) right justified in the display.
Sample Input
1111000 2 10
1111000 2 16
2102101 3 10
2102101 3 15
12312 4 2
1A 15 2
1234567 10 16
ABCD 16 15
Sample Output
120
78
1765
7CA
ERROR
11001
12D687
D071
此题目楼主眼花,没注意到题目说只有16个按钮,第一次敲代码时将负数算进去,a了好久。以下是正确代码:
思路:①将非十进制转换成十进制
②将十进制转换成任意进制(取余法)

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int fun(char x[],int y){ //fun函数将任意进制转化成十进制
	int str=strlen(x),sum=0,t=1,s=0;
	for(int i=str-1;i>=s;i--){
		int ss=0;
		if(x[i]<='9'&&x[i]>='0'){
			x[i]=x[i]-'0';
			ss=x[i]*t;
			t=t*y;
		}
		if(x[i]>='A'&&x[i]<='F'){
			x[i]=x[i]-'A'+10;
			ss=x[i]*t;
			t=t*y;
		}
	sum+=ss;	
	}
	return sum;
}
void fun1(int n,int r){//fun1函数将十进制转换成任意进制
	    int c=0,a[100];
        while(n)
        {
            a[c]=(n%r);
            c++;
            n/=r;
        }
        if(c>7)//*注意显示屏只能显示7位数字*
        printf("  ERROR");
        else{
        	for(int i=7;i>c;i--)
        	printf(" ");
        for(int i=c-1;i>=0;i--)
        {
            if(a[i]>=10)
            {
                printf("%c",'A'+a[i]-10);
            }
            else printf("%d",a[i]);
        }} 
        printf("\n");
	}
int main(){
	int m,n,c;
	char l[7];
	while(scanf("%s%d%d",l,&m,&n)!=EOF){
	        char x[7];
			strcpy(x,l);
			int num=m;
		if(n!=10)
			fun1(fun(l,m),n);
		if(n==10){
			if(fun(x,num)/10000000>0)
			printf("  ERROR\n");
			else
			printf("%7d\n",fun(l,m));
		}	
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值