Cube 其实作为小白的我不是很明白这道题存在的意思是什么。

As a student of the applied mathematics school of UESTC, WCM likes mathematics. Some day he found an interesting theorem that every positive integer’s cube can be expressed as the sum of some continuous odd positive integers.
For example,

111111 = 1331 = 111+113+115+117+119+121+123+125+127+129+131

Facing such a perfect theorem, WCM felt very agitated. But he didn’t know how to prove it. He asked his good friend Tom Riddle for help. Tom Riddle is a student of the computer science school of UESTC and is skillful at programming. He used the computer to prove the theorem’s validity easily. Can you also do it?

Given a positive integer N, you should determine how to express this number as the sum of N continuous odd positive integers. You only need to output the smallest and the largest number among the N integers.
Output
For each test case, output two integers on a line, the smallest and the largest number among the N continuous odd positive integers whose sum is N * N * N.
Sample Input
Raw
2
11
3
Sample Output
Raw
111 131
7 11

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
    	long long  b;
    	int num=1;
    	scanf("%lld",&b);
    	printf("%d %d\n",b*(b-1)+1,b*(b+1)-1);
	}
	return 0;        
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值