终于AC了 2008-02-19 23:24

荒废掉一个暑假从昨天起,开始做ACM的题了,今天在王彦学长的点拨下终于自己写的程序真正意义上的AC了太爽了.写下来纪念下.

题目如下:

H.   Cube

--------------------------------------------------------------------------------

Time Limit: 1.0 Seconds   Memory Limit: 65536K
Total Runs: 213   Accepted Runs: 83

--------------------------------------------------------------------------------


As a student of the applied mathematics school of UESTC, WCM likes mathematics. Some day he found an interesting theorem that every positive integer's cube can be expressed as the sum of some continuous odd positive integers.
For example,

11*11*11 = 1331 = 111+113+115+117+119+121+123+125+127+129+131

Facing such a perfect theorem, WCM felt very agitated. But he didn't know how to prove it. He asked his good friend Tom Riddle for help. Tom Riddle is a student of the computer science school of UESTC and is skillful at programming. He used the computer to prove the theorem's validity easily. Can you also do it?

Given a positive integer N, you should determine how to express this number as the sum of N continuous odd positive integers. You only need to output the smallest and the largest number among the N integers.


Input
The input contains an integer on the first line, which indicates the number of test cases. Each test case contains one positive integer N on a single line(0 < N ≤ 1000).

Output
For each test case, output two integers on a line, the smallest and the largest number among the N continuous odd positive integers whose sum is N * N * N.
Sample Input
2
11
3

Sample Output
111 131
7 11

其实这题还算容易的,就是在处理输入和存储时出现头疼的不知所措.最后问了学长,他点拨了下,使我开窍了哈!太感谢王彦学长了.

继续努力去!!!希望多点AC!

解题代码如下:

#include<stdio.h>
main()
{
  int n,a,max,min;
  scanf("%d",&n);
  while(n--)
   {  scanf("%d",&a);
      max=a*a+(a-1);
      min=a*a-(a-1);
      printf("%d %d/n",min,max);
   }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值