Android 6.0 之后无法找到 org.apache.http 包的问题

随着Android 6.0的sdk包的更新,发现找不到org.apache.http的包了,

这里写图片描述
大概意思就是,Android 6.0不再支持 Apache HTTP client。 请使用 HttpURLConnection 代替。想要继续使用 Apache HTTP client 的,请添加如上代码。

解决方法一
如上所述,

android {
    useLibrary 'org.apache.http.legacy'
    }

解决方法二
直接下载org.apache.http.legacy.jar这个jar包,加入libs文件夹就行了。

经过个人验证,还是用方法二比较简单,因为我在使用方法一的时候,因为项目之前是5.0的时候创建的,现在把sdk升级到23,结果加入这句话后,要修改很多地方,如果直接创建的时候就是23就没有问题了。

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Picasso_L/article/details/49946125
文章标签: android org-apache
上一篇Android过渡动画之共享元素实现以及遇到的一些问题
下一篇ViewPager的切换动画
想对作者说点什么? 我来说一句

org.apache.http

2014年04月24日 819KB 下载

没有更多推荐了,返回首页

关闭
关闭