Biorhythms HDU - 1370(中国剩余定理)

Some people believe that there are three cycles in a person’s life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.

Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days’’ even if the answer is 1.

Sample Input

1

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

题意:

有三个周期 分别为23,28 ,33天,给出每一个周期出现峰值的某一天,计算从题中给出的第d天到三个周期同时出现峰值的那一天一共有多少天?

注意当三峰值出现在第d天,则要输出下一个三峰值出现距离第d天有多少天

思路:

设出现三峰值那一天为第n天,则:

n%23=p

n%28=e

n%33=i

则有:

k1*(23*28)%33=1

k2*(23*33)%28=1

k3*(28*33)%23=1

k1,k2,k3用三个for循环求出

求解最小的n的公式为

(k1(2328)+k2(2333)+k3(28*33)%23=1)%lcm(23,28,33)*

最后计算从第d天到第n天有多少天即可

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int p,e,l,d,k=1;
        while(~scanf("%d %d %d %d",&p,&e,&l,&d)&&p+e+l+d!=-4)
        {
            int f,f1,f2;
            for(int i=0; i<33; i++)
            {
                if((23*28*i)%33==1)
                {
                    f=23*28*i;
                    break;
                }
            }
            for(int i=0; i<23; i++)
            {
                if((28*33*i)%23==1)
                {
                    f1=28*33*i;
                    break;
                }
            }
            for(int i=0; i<28; i++)
            {
                if((23*33*i)%28==1)
                {
                    f2=23*33*i;
                    break;
                }
            }
            int n;
            if(p==0&&e==0&&l==0)
                n=21252;
            else
                n=(f*l+f1*p+f2*e)%21252;
            if(n>d)
                n=n-d;
            else
                n=n+21252-d;
            printf("Case %d: the next triple peak occurs in %d days.\n",k++,n);
        }
    }
    return 0;
}
在C++中实现生物节奏(Biorhythms)算法通常涉及计算基于出生日期的三个周期性力量:体力(Physical)、情绪(Emotional),和智力(Intellectual)。这个算法最初由奥地利心理学家库尔特·冯·古拉赫(Kurt von Geber)在19世纪末提出。 以下是简单的步骤: 1. **获取用户出生信息**:首先,你需要用户的生日,通常是年、月、日的形式,用于计算三个基本周期的天数。 ```cpp struct Date { int day; int month; int year; }; Date userBirth; ``` 2. **计算周期长度**:每个周期的天数是固定的:体力23天,情绪28天,智力33天。从生日开始算起,直到这三个周期结束。 ```cpp const int PhysicalPeriod = 23; const int EmotionalPeriod = 28; const int IntellectualPeriod = 33; int physicalDays = (userBirth.year - 1970) * 365 + // 考虑公历闰年修正 (userBirth.month - 1) * 30 + userBirth.day; // 计算其他两个周期同理 ``` 3. **找出当前周期**:将当前日期减去周期起点得到剩余天数,判断余数落在哪个周期内。 4. **评估强度**:通常会创建一个分数系统,例如0到10分,然后根据剩余天数相对于周期的位置分配得分。 ```cpp float getStrength(int daysInCycle, int periodLength) { float strength = static_cast<float>(daysInCycle % periodLength) / periodLength; return std::clamp(strength, 0.f, 1.f); // 确保强度在合法范围内 } // 获取每个维度的得分 float physicalStrength = getStrength(physicalDays, PhysicalPeriod); float emotionalStrength = getStrength(emotionalDays, EmotionalPeriod); float intellectualStrength = getStrength(intellectualDays, IntellectualPeriod); ``` 5. **结果展示**:你可以选择将这些得分显示给用户,或者根据它们设计某种可视化表示。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值