Contest 2: Find all factors

Description

Output the number of total factors of an integer.

Input

There are several lines. And each line contains a positive number N (1<=N<=9999999999999999).

Output

Output the number of total factors for each N.
For example,
Input
12
20
Output
6
6
Because 1, 2, 3, 4, 6, 12 are factors of 12.
1,2,4,5,10,20 are are factors of 20.

Sample Input

12
20

Sample Output

6
6

HINT

#include <stdio.h>
#include <math.h>
 int main()
 {
     long int n, i,sq;
     int fac=0;
     while (scanf("%ld",&n)!=EOF)
     {   sq=sqrt(n);

         for(i=1;i<=sq;i++)
         {
              if(n%i==0)
                fac++;
         }
         fac*=2;
         float sqr=sq;
         if(sqr==sqrt(n))
            fac--;

     printf("%d\n",fac);
     fac=0;
     }
     return 0;
 }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值