POJ 2184 Cow Exhibition 01背包


一道01背包的变形,挺有趣的题:


题目:

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

思路:

看到题目中:两个变量,只有取和不取两种状态,明显就是01背包问题。题目中有正负值的问题需要注意。

具体解法见代码:

//By Sean Chen
#include <iostream>
#include <cstdio>
#include <cstring>
#define inf 0x3f3f3f3f
using namespace std;
int Max(int a,int b)
{
    if (a>b)
        return a;
    return b;
}
int dp[200005],si,fi,cnt;            //dp数组表示背包,dp[i]中的i表示s,dp[i]的值表示f,dp[i]+i-100000就表示TS+TF
int main()
{
    int n,s[200],f[200],ans;
    scanf("%d",&n);
    for(int i=0;i<=200000;i++)
        dp[i]=-inf;
    dp[100000]=0;
    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&s[i],&f[i]);
    }
    for(int i=0;i<n;i++)
    {
        if (s[i]<0 && f[i]<0)
            continue;
        if(s[i]>0)
        {
            for(int j=200000;j>=s[i];j--)
                if(dp[j-s[i]]>-inf)
                    dp[j]=Max(dp[j],dp[j-s[i]]+f[i]);
        }
        else
        {
            for(int j=s[i];j<=200000+s[i];j++)            //小于0时要注意!此处应反向。因为这个WA了一次。看大神的解题报告才发现问题
                if(dp[j-s[i]]>-inf)
                    dp[j]=Max(dp[j],dp[j-s[i]]+f[i]);
        }
    }
    ans=0;
    for(int i=100000;i<=200000;i++)            //0-99999表示TS为负数,100000-200000表示TS为非负数。所以该循环范围:100000-200000
    {
        if(dp[i]>=0)
            ans=Max(ans,dp[i]+i-100000);
    }
    printf("%d\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值