The Unique MST 2017 暑期 学习 次小生成树

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3
Not Unique!
本题问最小生成树是否唯一,若唯一,输出权值和,否则输出not unique。
判断最小生成树是否唯一,那我们就求次小生成树的权值和与最小生成树是否相同。
次小生成树求法:先求出最小生成树,并记录最小生成树所用的边,然后每次去掉最小生成树所用的一条边,再求一次最小生成树,并求这些最小生成树的权值的最小值。
代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct node
{
    int x,y,dis;
    int flag;
} a[10005];

int cmp(node x,node y)
{
    return x.dis<y.dis;
}
int root[105],n;

int findroot(int x)
{
    if (root[x]==x)
        return x;
    root[x]=findroot(root[x]);
    return root[x];
}

int kruskal(int num,int m)
{
    int ans=0,cnt=1;
    for (int i=0;i<m;i++)
    {
        if(i==num)
            continue;
        int r1=findroot(a[i].x);
        int r2=findroot(a[i].y);
        if (r1!=r2)
        {
            ans+=a[i].dis;
            cnt++;
            root[r2]=r1;
        }
    }
    if(cnt!=n)
        return -1;
    else
        return ans;
}

int main()
{
    int m,t,sum,ans,cnt;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<=n;i++)
            root[i]=i;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].dis);
            a[i].flag=0;
        }
        sort(a,a+m,cmp);
        cnt=1;
        ans=0;
        for (int i=0;i<m;i++)
        {
            int r1=findroot(a[i].x);
            int r2=findroot(a[i].y);
            if(r1!=r2)
            {
                a[i].flag=1;
                ans+=a[i].dis;
                cnt++;
                root[r2]=r1;
            }
        }
        int flag=0;
        for (int i=0;i<m;i++)
        {
            if(a[i].flag==0)
                continue;
            sum=0;
            for (int j=0;j<=n;j++)
                root[j]=j;
            sum=kruskal(i,m);
            if(sum==ans)
            {
                flag = 1;
                break;
            }
        }
        if(flag)
            printf("Not Unique!\n");
        else
            printf("%d\n",ans);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值