3D dungeon(BFS)

描述 You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

 

输入

 

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

 

输出

 

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

 

样例输入

 

 

 

3 4 5 S.... .###. .##.. ###.# ##### ##### ##.## ##... ##### ##### #.### ####E 1 3 3 S## #E# ### 0 0 0

 

 

样例输出

 

 

 

Escaped in 11 minute(s). Trapped!

 

该题大意:给一个多层地图,#为墙,从S出发走到E处,若能输出最短时间(每次只能上下左右,上一层,下一层移动,一次1分钟),若不能则输出Trapped!。

 

 

思路:可以理解成可向6个方向走的bfs,用3位数组存储地图。(还是需要勤加练习啊,实在是菜到家了)。

代码如下:

 

 

 

 

#include<stdio.h>
#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
char a[100][100][100];
int vis[100][100][1000];//访问数组,判断是否访问过
int k,n,m,i,j,h;
int f[6][3]={{0,1,0},{0,0,1},{0,-1,0},{0,0,-1},{-1,0,0},{1,0,0}};//6个可走的方向
struct node
{
    int x,y,z,t;
} s,em;
int bfs(int x1,int y1,int z1,int t)
{
    queue<node>q;
    s.x=x1;
    s.y=y1;
    s.z=z1;
    vis[x1][y1][z1]=1;
    s.t=t;
    q.push(s);
    while(!q.empty())
    {
        s=q.front();
        q.pop();
        for(i=0;i<6;i++)
        {
            em.x=s.x+f[i][0];
            em.y=s.y+f[i][1];
            em.z=s.z+f[i][2];
            if(em.x>=0&&em.x<k&&em.y>=0&&em.y<n&&em.z>=0&&em.z<m&&vis[em.x][em.y][em.z]==0&&a[em.x][em.y][em.z]!='#')//判别下一步的条件
            {
                em.t=s.t+1;
                if(a[em.x][em.y][em.z]=='E')
                {
                    return em.t;
                }
                vis[em.x][em.y][em.z]=1;//标记已走过改点
                q.push(em);
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d%d%d",&k,&n,&m)!=EOF)
    {
        if(k==0&&n==0&&m==0)
        {
            break;
        }
        memset(vis,0,sizeof(vis));
        int x1,y1,z1;
        for(i=0;i<k;i++)
        {
            for(j=0;j<n;j++)
            {
                for(h=0;h<m;h++)
                {
                    cin>>a[i][j][h];//注意:如果用scanf输入需要用getchar吸收回车
                    if(a[i][j][h]=='S')
                    {
                        x1=i;
                        y1=j;
                        z1=h;
                    }
                }
            }
        }
        int fag;
        fag=bfs(x1,y1,z1,0);
        if(fag==-1)
        {
            printf("Trapped!\n");

        }
        else
        {
            printf("Escaped in %d minute(s).\n",fag);
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值