Decimal integer conversion(枚举)

描述 XiaoMing likes mathematics, and he is just learning how to convert numbers between differentbases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts anumber to a new base and writes down the result, he always writes one of the digits wrong.For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be"1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds ordeletes digits, so he might write down a number with a leading digit of " 0" if this is the digit shegets wrong.Given XiaoMing 's output when converting a number N into base 2 and base 3, please determinethe correct original value of N (in base 10). (N<=10^10)You can assume N is at most 1 billion, and that there is a unique solution for N. 

 

输入

 

The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8)
Each test case specifies:
* Line 1: The base-2 representation of N , with one digit written incorrectly.
* Line 2: The base-3 representation of N , with one digit written incorrectly.

 

输出

 

For each test case generate a single line containing a single integer , the correct value of N

 

样例输入

 

 

 

 

 

1

1010

212

 

 

样例输出

 

 

 

14

题目大意:多组数据输入,每组输入2个数据,一个为2进制一个为3进制,这2个数据都由一个十进制数转化而来但可能某位移动了(1变成0或位置变化了),需要求出原来的十进制数。

 

 

思路:枚举。因为是变化和移动,那就枚举二进制数的状态,将其转化为三进制数再与第二个数据比较,若只有一位不同则该枚举状态即为所求十进制数。读懂题思路还是比较清晰的。

代码如下:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<string>
#include<stdio.h>
using namespace std;
int fun(string s1,string s2)
{
    int flag=0,i,j,k=s2.size(),l=0;
    int n=0;
    string s3;
    for(i=0;i<s1.size();i++)
    {
        n=n*2+s1[i]-'0';//把该状态转化为十进制数    
    }
    int z=n;
    while(k!=0)//因为2个数据都由一个数转变而来,所以数位相差不大(感觉自己有点钻空了)
    {
        s3[k-1]=n%3+'0';
        k--;
        n=n/3;//转化为三进制数
    }
    for(i=0;i<s2.size();i++)
    {
        if(s3[i]!=s2[i])
        {
            l++;
            if(l>1)
            return 0;      
        }
    }
    if(l==1)
    {
        printf("%d\n",z); 
        return 1;
    }
}
int main()
{
    int i,j,t;
    string s1,s2;
    scanf("%d",&t);
    while(t--)
    {
        cin>>s1>>s2;
        for(i=0;i<s1.size();i++)
        {
            int fag=0;
            s1[i]=(s1[i]-'0'+1)%2+'0';//0变1,1变0
            fag=fun(s1,s2);
            if(fag==1)
            break;        
            s1[i]=(s1[i]-'0'+1)%2+'0';//变回去      
        }
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值