Decimal integer conversion

问题 F: Decimal integer conversion

时间限制: 1 Sec   内存限制: 64 MB
提交: 9   解决: 7
[ 提交][ 状态][ 讨论版]

题目描述

XiaoMing likes mathematics, and he is just learning how to convert numbers between different bases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts a number to a new base and writes down the result, he always writes one of the digits wrong. For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be "1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds or deletes digits, so he might write down a number with a leading digit of " 0" if this is the digit she gets wrong. Given XiaoMing 's output when converting a number N into base 2 and base 3, please determine the correct original value of N (in base 10). (N<=10^10) You can assume N is at most 1 billion, and that there is a unique solution for N. 

输入

The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8) Each test case specifies: * Line 1: The base-2 representation of N , with one digit written incorrectly. * Line 2: The base-3 representation of N , with one digit written incorrectly.

输出

For each test case generate a single line containing a single integer , the correct value of N

样例输入

1
1010
212

样例输出

14
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
char a[1000];
char b[1000];
int a1[1000],b1[1000];
int qp(int n,int m)
{
    int sum=1;
    while(m)
    {
        if(m&1)
            sum=sum*n;
        n=n*n;
        m=m>>1;
    }
    return sum;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",a);
        scanf("%s",b);
        memset(a1,0,sizeof(a1));
        memset(b1,0,sizeof(b1));
        int l=strlen(a);
        int l1=strlen(b);
        int p1=0;
        for(int i=0;i<l;i++)
        {
            a[i]=(a[i]-'0'+1)%2+'0';
            int ni=0;
            int sum=0;
            for(int j=l-1;j>=0;j--)
            {
                sum+=(a[j]-'0')*qp(2,ni);
                ni++;
            }
            a1[p1++]=sum;
            a[i]=(a[i]-'0'+1)%2+'0';
        }
        int p2=0;
        char we;
        for(int i=0;i<l1;i++)
        {
            we=b[i];
            b[i]=(b[i]-'0'+1)%3+'0';
            int ni=0;
            int sum=0;
            for(int j=l1-1;j>=0;j--)
            {
                sum+=(b[j]-'0')*qp(3,ni);
                ni++;
            }
            b1[p2++]=sum;
            b[i]=(b[i]-'0'+1)%3+'0';
            int ni1=0;
            int sum1=0;
            for(int j=l1-1;j>=0;j--)
            {
                sum1+=(b[j]-'0')*qp(3,ni1);
                ni1++;
            }
            b1[p2++]=sum1;
            b[i]=we;
        }
        int o=0;
        for(int i=0;i<p1;i++)
        {
            for(int j=0;j<p2;j++)
            {
                if(a1[i]==b1[j])
                {
                    printf("%d\n",a1[i]);
                    o=1;
                    break;
                }
            }
            if(o==1)
                break;
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值