题目描述:
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
输入:
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
输出:
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
样例输入:
ababcababababcabab
aaaaa
样例输出:
2 4 9 18
1 2 3 4 5
code:
题目大意:
给定一个字符串s,有哪些长度的s的前缀,同时也是s的后缀。
使用KMP算法的next[ ]数组,即可完成这一个要求
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<set>
using namespace std;
const int maxn=1e6+10;
char a[maxn];
int nextt[maxn];
int n;
void init()
{
int i=0,j=-1;
n=strlen(a);
nextt[0]=-1;
int maxx=1;
while(i<n)
{
if(j==-1||a[i]==a[j])
{
i++;
j++;
nextt[i]=j;
}
else j=nextt[j];
}
}
void print(int what)
{
if(what==0)return ;
print(nextt[what]);
printf("%d ",what);
}
int main()
{
while(scanf("%s",a)!=EOF)
{
init();
print(nextt[strlen(a)]);
printf("%d\n",strlen(a));
}
return 0;
}