Building Block

题目描述:

John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1…N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command.
C X : Count the number of blocks under block X

You are request to find out the output for each C operation.

输入:

The first line contains integer P. Then P lines follow, each of which contain an operation describe above.

输出:

Output the count for each C operations in one line.

样例输入:

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

样例输出:

1
0
2

带权并查集,在带本身和不带本身之间犹豫了好久,发现怎么试都不行
最后发现组合起来就可以了

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int father[40000];
int sum[40000];//不包括他自己本身在内的砖块数量
int num[40000];//包括他自己本身在内的一下的砖块数量
int findd(int a)
{
	if(father[a]==a)return a;
	else
	{
		int t=father[a];
		father[a]=findd(father[a]);
		sum[a]+=sum[t];
		return father[a];
	}
}
void unit(int a,int b)
{
	int x=findd(a);
	int y=findd(b);
	if(x==y)return ;
	father[x]=y;
	sum[x]=num[y];
	num[y]+=num[x];
	num[x]=0;
}
int main()
{
	int n;
	scanf("%d",&n);
	memset(sum,0,sizeof(sum));
	string bb;
	for(int i=0;i<=30000;i++)
	{
		father[i]=i;
		num[i]=1;
	}
	while(n--)
	{
		cin>>bb;
		if(bb=="M")
		{
			int a,b;
			scanf("%d%d",&a,&b);
			unit(a,b);
		}
		else
		{
			int a;
			scanf("%d",&a);
			findd(a);
			printf("%d\n",sum[a]);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值