String Problem kmp+最大最小表示法

题目描述:

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

输入:

Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

输出:

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

样例输入:

abcder
aaaaaa
ababab

样例输出:

1 1 6 1
1 6 1 6
1 3 2 3

code:

题意:
输出所给字符串的最大最小表示的起始位置和数量
思路
数量我们可以利用KMP里的求next数组,然后再套用一下最大最小表示法的模板

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn=1e6+50;
char a[maxn];
char b[maxn];
int nexxt[maxn];
void init()
{
	int i=0,j=-1;
	int n=strlen(a);
	nexxt[0]=-1;
	while(i<n)
	{
		if(j==-1||a[i]==a[j])
		{
			i++;
			j++;
			nexxt[i]=j;
		}
		else j=nexxt[j];
	}
}
int getmin()
{
	int n=strlen(a);
	int i=0,j=1,k=0;
	while(i<n&&j<n&&k<n)
	{
		int tt=a[(i+k)%n]-a[(j+k)%n];
		if(tt==0)k++;
		else
		{
			if(tt>0)i+=k+1;
			else j+=k+1;
			if(i==j)j++;
			k=0;
		}
	}
	return min(i,j);
}
int getmax()
{
	int n=strlen(a);
	int i=0,j=1,k=0;
	while(i<n&&j<n&&k<n)
	{
		int tt=a[(i+k)%n]-a[(j+k)%n];
		if(tt==0)k++;
		else
		{
			if(tt>0)j+=k+1;
			else i+=k+1;
			if(i==j)j++;
			k=0;
		}
	}
	return min(i,j);
}
int main()
{
	while(scanf("%s",&a)!=EOF)
	{
		init();
		int n=strlen(a);
		int what=1;
		if(n%(n-nexxt[n])==0)what=n/(n-nexxt[n]);
		int minn=getmin();
		int maxx=getmax();
		printf("%d %d %d %d\n",minn+1,what,maxx+1,what);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值