Girls' research

题目描述:

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, “abcde”, but ‘a’ inside is not the real ‘a’, that means if we define the ‘b’ is the real ‘a’, then we can infer that ‘c’ is the real ‘b’, ‘d’ is the real ‘c’ ……, ‘a’ is the real ‘z’. According to this, string “abcde” changes to “bcdef”.
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.

输入:

Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real ‘a’ is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.

输出:

Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output “No solution!”.
If there are several answers available, please choose the string which first appears.

样例输入:

b babd
a abcd

样例输出:

0 2
aza
No solution!

code:

题目大意:找到最长的那个回文字符串
思路:manacher算法

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char feng[420000];
char jiang[460000];
int huang[460000];
void init()
{
	int j=0;
	int len=strlen(feng);
	jiang[j++]='$';
	jiang[j++]='#';
	for(int i=0;i<len;i++)
	{
		jiang[j++]=feng[i];
		jiang[j++]='#';
	}
	jiang[j]='\0';
}
void manacher(int what)
{
	init();
	int len=strlen(jiang);
	int mx=0,maxx=-1,id=0;
	int start,over;
	for(int i=1;i<len;i++)
	{
		if(i<mx){
			huang[i]=min(huang[id*2-i],mx-i);
		}
		else{
			huang[i]=1;
		}
		while(jiang[i-huang[i]]==jiang[i+huang[i]])huang[i]++;
		if(huang[i]+i>mx){
			mx=huang[i]+i;
			id=i;
		}
		if(huang[i]>huang[maxx])
		{
			maxx=i;
		}
	}
	if(huang[maxx]>2)
	{
		start=(maxx-huang[maxx])/2;
		over=(maxx+huang[maxx])/2;
		over-=2; 
		printf("%d %d\n",start,over);
		for(int i=start;i<=over;i++)
		{
			feng[i]+=what;
			if(feng[i]<'a')feng[i]+=26;
			printf("%c",feng[i]);
		}
		printf("\n");
	}
	else printf("No solution!\n");
}
int main()
{
	char a[3];
	while(scanf("%s%s",a,feng)!=EOF)
	{
		int what='a'-a[0];
		manacher(what);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值