Theme Section

题目描述:

It’s time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a ‘theme section’. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of ‘EAEBE’, where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters ‘a’ - ‘z’.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?

输入:

The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.

输出:

There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

样例输入:

5
xy
abc
aaa
aaaaba
aaxoaaaaa

样例输出:

0
0
1
1
2

code:

一大堆英语堆积在一起。。。。。。
又像是回到了做阅读理解的时候
题目大意:
求前面有,后面也有,中间还有的字符串的长度
KMP算法

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn=1e6+50;
char a[maxn];
char b[maxn];
int nexxt[maxn];
void init()
{
	int i=0,j=-1;
	int n=strlen(a);
	nexxt[0]=-1;
	while(i<n)
	{
		if(j==-1||a[i]==a[j])
		{
			i++;
			j++;
			nexxt[i]=j;
		}
		else j=nexxt[j];
	}
}
bool kmp(int what)
{
	int i=what,j=0;
	int n=strlen(a)-what;
	while(i<n)
	{
		if(j==-1||a[i]==a[j])
		{
			i++;
			j++;
		}
		else j=nexxt[j];
		if(j==what)return true;
	}
	return false;
}
int main()
{
	int ttt;
	scanf("%d",&ttt);
	while(ttt--)
	{
		scanf("%s",&a);
		init();
		int n=strlen(a);
		int what=nexxt[n];
		int ans=0;
		while(what)
		{
			if(kmp(what))
			{
				ans=max(ans,what);
				break;
			}
			what=nexxt[what];
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值