Antenna Placement

题目描述:

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.

本题对应图片

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?

 

输入:

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space.

输出:

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

样例输入:

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

样例输出:

17
5

code:

蒟蒻最近在看二分图问题,然而只会打模板,并且对模板领会的还不太好

先说这一道题吧,稍微变化一点的模板题

输出结果为:总城市数-最大匹配数

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
const int maxn=450;
bool visit[maxn];
int match[maxn];
int city[45][20];
vector<int> g[maxn];
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};
int n,m,number;
void add_edge(int u,int v){
	g[u].push_back(v);
	g[v].push_back(u);
}
bool dfs(int v){
	visit[v]=true;
	for(int i=0;i<g[v].size();i++){
		int u=g[v][i],w=match[u];
		if(w<0||!visit[w]&&dfs(w)){
			match[u]=v;
			match[v]=u;
			return true;
		}
	}
	return false;
}
int findd(){
	int res=0;
	memset(match,-1,sizeof(match));
	for(int v=1;v<=number;v++){
		if(match[v]<0){
			memset(visit,0,sizeof(visit));
			if(dfs(v))res++;
		}
	}
	return res;
}
int main()
{
	int ttt;
	scanf("%d",&ttt);
	while(ttt--){
		scanf("%d%d",&n,&m);
		number=0;
		char feng[50];
		memset(city,0,sizeof(city));
		for(int i=1;i<=n;i++){
			scanf("%s",feng);
			for(int j=1;j<=m;j++){
				if(feng[j-1]=='*')
					city[i][j]=++number;
			}
		}
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				if(city[i][j]>0){
					for(int k=0;k<4;k++){
						int xx=dx[k]+i;
						int yy=dy[k]+j;
						if(xx>=1&&xx<=n&&yy>=1&&yy<=m&&city[xx][yy]>0){
							add_edge(city[xx][yy],city[i][j]);
						}
					}
				}
			}
		}
		printf("%d\n",number-findd());
		for(int i=0;i<maxn;i++){
			g[i].clear();
		}
	}
	return 0;
 } 

学完匈牙利算法后再来一波

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
const int maxn=450;
int city[50][50];
int n,m,number;
int pre[maxn];
int visit[maxn];
vector<int> match[maxn];
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};
void init(){
	for(int i=0;i<maxn;i++){
		match[i].clear();
	}
	memset(pre,0,sizeof(pre));
	memset(city,0,sizeof(city));
	number=0;
}
bool dfs(int x){
	for(int i=0;i<match[x].size();i++){
		int j=match[x][i];
		if(visit[j]==0){
			visit[j]=1;
			if(pre[j]==0||dfs(pre[j])){
				pre[j]=x;
				return true;
			}
		}
	}
	return false;
}
int findd(){
	int sum=0;
	for(int i=1;i<=number;i++){
		memset(visit,0,sizeof(visit));
		if(dfs(i))sum++;
	}
	return sum;
}
void add_edge(int x,int y){
	match[x].push_back(y);
	match[y].push_back(x);
}
int main()
{
	int ttt;
	scanf("%d",&ttt);
	while(ttt--){
		scanf("%d%d",&n,&m);
		char feng[50];
		init();
		for(int i=0;i<n;i++){
			scanf("%s",feng);
			for(int j=0;j<m;j++){
				if(feng[j]=='*')city[i][j]=++number;
			}
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(city[i][j]){
					for(int k=0;k<4;k++){
						if(city[i+dx[k]][j+dy[k]]){
							add_edge(city[i][j],city[i+dx[k]][j+dy[k]]);
						}
					}
				}
			}
		}
		printf("%d\n",number-findd()/2);
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值