Stones

题目描述:

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

输入:

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

输出:

Just output one line for one test case, as described in the Description.

样例输入:

2
2
1 5
2 4
2
1 5
6 6

样例输出:

11
12

在这里我还是想吐槽一下机翻,那个奇数块石头我还真的是没有看懂,后来翻了别人的博客才知道,原来是遇到的第几块石头??
我还以为是一堆奇数个石头呢。。。。
一道典型的优先队列
如果这是你遇到的第奇数个石头,就扔,反之,就不管,问最远的石头有多远

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
struct node{
	long long yuan,wei;
	friend operator<(node a,node b)
	{
		if(a.wei==b.wei)return a.yuan>b.yuan;
		else return a.wei>b.wei;
	}
};
int main()
{
	int ttt;
	scanf("%d",&ttt);
	while(ttt--)
	{
		priority_queue<node> feng;
		long long n;
		scanf("%lld",&n);
		node d;
		for(int i=0;i<n;i++)
		{
			scanf("%lld%lld",&d.wei,&d.yuan);
			feng.push(d);
		}
		long long count=1;
		long long maxx=0;
		while(!feng.empty())
		{
			d=feng.top();
			maxx=max(d.wei,maxx);
			feng.pop();
			if(count%2==1)
			{
				d.wei=d.wei+d.yuan;
				d.yuan=d.yuan;
				feng.push(d);
			}
			count++;
		}
		printf("%lld\n",maxx);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值