Cow Contest

题目描述:

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

输入:

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

输出:

  • Line 1: A single integer representing the number of cows whose ranks can be determined

样例输入:

5 5
4 3
4 2
3 2
1 2
2 5

样例输出:

2

题目大意:

题意是给出m对牛的相互关系,求有多少个牛排名是确定的。
用floyed求传递闭包。如果一个牛和其余的牛关系都是确定的,那么这个牛的排名就是确定的了。

code:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int n,m;
const int inf=9999999;
int a[105][105];
int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				a[i][j]=inf;
			}
		}
		for(int i=0;i<m;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			a[x][y]=1;
		}
		for(int k=1;k<=n;k++)
		{
			for(int i=1;i<=n;i++)
			{
				for(int j=1;j<=n;j++)
				{
					if(a[i][k]==1&&a[k][j]==1)
					{
						a[i][j]=1;
					 } 
				}
			}
		}
		int sum=0,num=0;
		for(int i=1;i<=n;i++)
		{
			sum=0;
			for(int j=1;j<=n;j++)
			{
				if(i!=j)
				{
					if(a[i][j]==1||a[j][i]==1)sum++;
				}
			}
			if(sum==n-1)num++;
		 } 
		printf("%d\n",num);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值