HDU 5832 A water problem【大数问题】

32 篇文章 0 订阅

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5814    Accepted Submission(s): 1238


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is  73  days in Xixi a year and  137  days in Haha a year. 

Now you know the days  N  after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 

Input
There are several test cases(about  5  huge test cases).

For each test, we have a line with an only integer  N(0N) , the length of  N  is up to  10000000 .
 

Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 

Sample Input
  
  
10001 0 333
 

Sample Output
  
  
Case #1: YES Case #2: YES Case #3: NO
 
可参见   c++大数模板
AC:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
typedef long long LL;
const int INF =0x7FFFFFFF;

const int M=1e7+1;
char str[M];
int i,j,n,k,m;

int cheak(char str[])
{
     int ans=0,cnt=0;
     int len=strlen(str);
        for(i=0;i<len;i++)
           ans=(ans*10+str[i]-'0')%10001;
           if(ans==0)return 1;
           else return 0;
}


int main()
{
   int k=1;
   while(gets(str))
   {
       if(cheak(str))
        printf("Case #%d: YES\n",k);
       else printf("Case #%d: NO\n",k);
       k++;
   }
   return 0;
}
比赛时一直TLE,原因:①cin②string
发誓,以后再也不用cin!!!

TLE:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
typedef long long LL;
const int INF =0x7FFFFFFF;

const int M=1e7+1;
string str;
int i,j,n,k,m;

int cheak(string str)
{
     int ans=0,cnt=0;
        for(i=0;i<str.length();i++)
           ans=(ans*10+str[i]-'0')%10001;
           if(ans==0)return 1;
           else return 0;
}


int main()
{
   int k=1;
   while(getline(cin,str))
   {
       if(cheak(str))
        printf("Case #%d: YES\n",k);
       else printf("Case #%d: NO\n",k);
       k++;
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值