POJ 3414 Pots【BFS】

 Pots
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)
 
    
 
    
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
typedef long long LL;
const int INF=0x7ffffff;

const int M=1e4+1;
int A,B,C;
int i,j,k,n,m;
int vis[110][110];

struct Node
{
    int a,b;
    int step;
    string s[110];
};

bool BFS()
{
    Node u,next;
    u.a=0;u.b=0;u.step=0;
    queue<Node>Q;
    Q.push(u);
    vis[0][0]=1;
    while(!Q.empty())
    {
        u=Q.front();
        Q.pop();
        if(u.a==C||u.b==C){
            printf("%d\n",u.step);
            for(int i=1;i<=u.step;i++){
               cout<<u.s[i]<<endl;
            }
            return true;
        }
        if(u.a==0){
            next=u;next.a=A;next.step++;
            next.s[next.step]="FILL(1)";
            if(!vis[next.a][next.b]){
                vis[next.a][next.b]=1;
                Q.push(next);
            }
        }
        if(u.a<=A&&u.a){
            next=u;next.a=0;next.step++;
            next.s[next.step]="DROP(1)";
            if(!vis[next.a][next.b]){
                vis[next.a][next.b]=1;
                Q.push(next);
            }
        }
        if(u.b<B&&u.a){
            next=u;next.step++;
            if(next.a+next.b<=B){
                next.b+=next.a;
                next.a=0;
            }
            else{
                next.a=next.a+next.b-B;
                next.b=B;
            }
            next.s[next.step]="POUR(1,2)";
            if(!vis[next.a][next.b]){
                vis[next.a][next.b]=1;
                Q.push(next);
            }
        }
        if(u.b==0){
            next=u;next.b=B;next.step++;
            next.s[next.step]="FILL(2)";
            if(!vis[next.a][next.b]){
                vis[next.a][next.b]=1;
                Q.push(next);
            }
        }
        if(u.b<=B&&u.b){
            next=u;next.b=0;next.step++;
            next.s[next.step]="DROP(2)";
            if(!vis[next.a][next.b]){
                vis[next.a][next.b]=true;
                Q.push(next);
            }
        }
        if(u.a<A&&u.b){
            next=u;next.step++;
            if(next.a+next.b<=A){
                next.a+=next.b;
                 next.b=0;
            }
            else{
                next.b=next.a+next.b-A;
                next.a=A;

            }
            next.s[next.step]="POUR(2,1)";
            if(!vis[next.a][next.b]){
                vis[next.a][next.b]=true;
                Q.push(next);
            }
        }
    }
    return false;
}
int main()
{
    while(~scanf("%d%d%d",&A,&B,&C))
    {
        MS(vis,0);
        if(!BFS())
            printf("impossible\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值