HDU 1394 Minimum Inversion Number

 Minimum Inversion Number
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 

Output

For each case, output the minimum inversion number on a single line. 

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16
 
    
<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long LL;
const int INF=0x7ffffff;

const int MX = 5000+10;
int sum[MX<<2];
void PushUp(int rt) {
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];  
}

void Build(int l,int r,int rt) {
    sum[rt]=0;            
    if(r==l) return ;
    int    m=(r+l)>>1;
    Build(lson);
    Build(rson);
}

void UpData(int p,int l,int r,int rt) {
    if(r==l) {            
        sum[rt]++;
        return ;
    }
    int m=(r+l)>>1;
    if(p<=m) UpData(p,lson);  
    if(p >m) UpData(p,rson);
    PushUp(rt);
}
int Query(int L,int R,int l,int r,int rt) {
    if(L<=l&&R>=r)        
        return sum[rt];
    int m=(r+l)>>1;
    int ret=0;
    if(L<= m) ret += Query(L,R,lson);  
    if(R > m) ret += Query(L,R,rson);  
    return ret;
}
int x[MX];
int main() {
    int n;
    int sums;
    char s[2];
    while(~scanf("%d",&n)) {
        sums=0;            
        Build(0,n-1,1);        
        for(int i=0; i<n; i++) {
            scanf("%d",&x[i]);
            sums+=Query(x[i],n-1,0,n-1,1);
            UpData(x[i],0,n-1,1);
        }
        int ret=sums;
        for(int i=0; i<n; i++) {
            sums=sums+n-2*x[i]-1;
            ret=min(ret,sums);
        }
        printf("%d\n",ret);
    }
    return 0;
}


 
   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值