HDU 1394 Minimum Inversion Number

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21644    Accepted Submission(s): 12938


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2

Sample Output
16  
分析:一个长度为n的序列,由0!n-1组成,能循环移动n次,求解,这n个序列逆序数总数最小的时候,总数是多少?

5000的长度,每次重新往树状数组里面放复杂度O(n*n*lgn),绝逼超时。

然而,这个题目特殊在于这0~n-1个数,所以每次循环移位,下一个情况的总数都能算出来。

代码如下:


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

int tree[5005];
int reflect[5005];
int t;
void add(int x)
{
    for(int i=x;i<=t;i+=i&-i)
        tree[i]+=1;
}
int read(int x)
{
    int sum=0;
    for(int i=x;i>0;i-=i&-i)
        sum+=tree[i];
    return sum;
}
int main()
{
    int a,b;
    while(~scanf("%d",&t))
    {
        memset(tree,0,sizeof(tree));
        for(int i=1;i<=t;i++)
        {
            scanf("%d",&reflect[i]);
            reflect[i]++;
        }
        long long ans = 0;
		for(int i=1;i<=t;i++){
            ans += i - 1 - read(reflect[i]);
            add(reflect[i]);
        }
        int tem,sum;
        sum=ans;
        for(int i=1;i<=t;i++){
            int tem=sum-(reflect[i]-1)+t-reflect[i];
            sum=tem;
            if(ans>tem)
                ans=tem;
        }
    	printf("%lld\n", ans);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值