POJ 1011 Sticks【DFS】

30 篇文章 0 订阅
Sticks
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%lld & %llu

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5
 
    

思路:dfs+剪枝。

具体的实现:求出总长度sum和小棒最长的长度max,则原棒可能的长度必在max~sum之间,然后从小到大枚举max~sum之间能被sum整除的长度len,用dfs求出所有的小棒能否拼凑成这个长度,如果可以,第一个len就是答案。

 

dfs的实现和剪枝的设计:

      1.以一个小棒为开头,用dfs看看能否把这个小棒拼凑成len长,如果可以,用vis[i]记录下用过的小棒,然后继续以另外一个小棒为开头,以此类推。

      2.小棒的长度从大到小排序,这个就不解释了。

      3.如果当前最长的小棒不能拼成len长,那么就返回前一步,更改前一步的最长小棒的组合情况(这里不能是全部退出),不用再继续搜索下去了。

      4.最重要的,就是比如说17,9,9,9,9,8,8,5,2……如果当前最长小棒为17,它与第一个9组合之后dfs发现不能拼成len,那么17就不用和后面所有的9组合了,而直接和8开始组合。

 
    
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long LL;
const int INF=0x7ffffff;
#define lson rt<<1, l, m
#define rson rt<<1|1, m+1, r

const int M=100;
int n,len,st[M];
bool flag,vis[M];
int i,j,k,m;

bool cmp(int a,int b)
{
    return a>b;
}
void dfs(int now_num,int now_long,int u)
{
    if(flag)return;
    if(now_long==len){
        if(now_num==n)flag=1;
        else dfs(now_num,0,0);
        return;
    }
    if(now_long==0){
        int k=0;
        while(vis[k])k++;
        vis[k]=1;
        dfs(now_num+1,st[k],k+1);
        vis[k]=0;
        return;
    }
    for(int i=u;i<n;i++)
        if(!vis[i]&&now_long +st[i]<=len){
            if(!vis[i-1]&&st[i]==st[i-1])continue;
            vis[i]=1;
            dfs(now_num+1,now_long+st[i],i+1);
            vis[i]=0;
        }
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)break;
        int sum=0;
        flag=0;
        for(i=0;i<n;i++){
            scanf("%d",&st[i]);
            sum+=st[i];
        }
        sort(st,st+n,cmp);
        for(len=st[0];len<sum;len++)
            if(sum%len==0){
                MS(vis,0);
                dfs(0,0,0);
                if(flag)break;
            }
        printf("%d\n",len);
    }
    return 0;
}
 
   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值